Tapestry
  1. Tapestry
  2. TAPESTRY-1452

RedirectException does not work on Safari

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 4.0.2
    • Fix Version/s: 4.1.2
    • Component/s: Framework
    • Labels:
      None
    • Environment:
      OS X 10.4.7 with Safari 2.0.4 as well as nightly Webkit

      Description

      Throwing a RedirectException does not work on Safari. It works fine on IE6, IE7, FIrefox.

      The error that Safari displays is:

      Safari can't open the page.
      Safari can't open the page "http://localhost/Test.external". The error was: "bad server response" (NSURLErrorDomain:-1011) Please choose Report Bug to Apple from the Safari menu, note the error number, and describe what you did before you saw this message.

      Sample to reproduce problem:

      .java file:

      public abstract class Test extends BasePage implements IExternalPage {

      public void activateExternalPage(Object[] parameters, IRequestCycle cycle)

      { throw new RedirectException("http://www.yahoo.com"); }

      }

      .page file:

      <?xml version="1.0" encoding="UTF-8"?>
      <!DOCTYPE page-specification PUBLIC
      "-//Apache Software Foundation//Tapestry Specification 4.0//EN"
      "http://jakarta.apache.org/tapestry/dtd/Tapestry_4_0.dtd">
      <page-specification class="sample.Test">
      </page-specification>

      .html file:
      The html file can be left blank

        Activity

        Jesse Kuhnert added a comment -

        Works for me testing against safari 2.0.4 as well as the latest nightly webkit as of today against tapestry 4.1.2.


          People

          • Assignee:
            Jesse Kuhnert
            Reporter:
            Joseph Chen
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development