Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 4.1.2
    • Fix Version/s: 4.1.2
    • Component/s: Core Components
    • Labels:
      None

      Description

      There is a bug into Relation.java

      the compromising line is:
      public abstract boolean getUseBody();
      since it is a boolean, should be
      public abstract boolean isUseBody();

      1. Relation.diff
        2 kB
        Andrea Chiumenti
      2. Relation.diff
        2 kB
        Andrea Chiumenti

        Activity

        Andrea Chiumenti created issue -
        Andrea Chiumenti added a comment -

        hereit is the diff file

        Andrea Chiumenti made changes -
        Field Original Value New Value
        Attachment Relation.diff [ 12356061 ]
        Andrea Chiumenti added a comment -

        Sorry, my netbeans did something strange, THI IS THE PATCH

        Andrea Chiumenti made changes -
        Attachment Relation.diff [ 12356062 ]
        Andreas Andreou added a comment -

        Can you attach an example of how to reproduce this using only the Style or the Relation components?

        Cause this may very well be an ognl issue - so, changing the getters is just a workaround...
        And also getUseBody is a totally acceptable way of creating boolean getters - so,
        without more info, I'm inclined to closing this as a 'Cannot reproduce'

        Andreas Andreou made changes -
        Priority Blocker [ 1 ] Minor [ 4 ]
        Andrea Chiumenti added a comment -

        Ok, as you said, it was ognl, today that I have the ognl updated version is fine

        Andrea Chiumenti made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Fixed [ 1 ]
        Mark Thomas made changes -
        Workflow jira [ 12402475 ] Default workflow, editable Closed status [ 12568114 ]
        Mark Thomas made changes -
        Workflow Default workflow, editable Closed status [ 12568114 ] jira [ 12591205 ]

          People

          • Assignee:
            Unassigned
            Reporter:
            Andrea Chiumenti
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development