Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.1.2
    • Fix Version/s: 4.1.2
    • Component/s: Framework
    • Labels:
      None

      Description

      I'm getting the Exception-Page, and, additionally, the logs say:

      org.apache.hivemind.ApplicationRuntimeException: Unable to add method java.lang.Object get(ognl.OgnlContext, java.lang.Object) to class ognl.ASTMethod5188636Accessor: [source error] syntax error near "etAsset(.getMeldung("
      at org.apache.tapestry.enhance.ClassFabImpl.addMethod(ClassFabImpl.java:278)
      at org.apache.tapestry.services.impl.HiveMindExpressionCompiler.compileExpression(HiveMindExpressionCompiler.java:151)
      at ognl.OgnlRuntime.compileExpression(OgnlRuntime.java:388)
      at ognl.Ognl.compileExpression(Ognl.java:123)
      at org.apache.tapestry.services.impl.ExpressionCacheImpl.parse(ExpressionCacheImpl.java:129)
      at org.apache.tapestry.services.impl.ExpressionCacheImpl.getCompiledExpression(ExpressionCacheImpl.java:91)
      at $ExpressionCache_111bc7a6a5d.getCompiledExpression($ExpressionCache_111bc7a6a5d.java)
      at org.apache.tapestry.binding.ExpressionBinding.resolveExpression(ExpressionBinding.java:120)
      at org.apache.tapestry.binding.ExpressionBinding.getObject(ExpressionBinding.java:111)
      at org.apache.tapestry.binding.AbstractBinding.getObject(AbstractBinding.java:84)
      at $Image_7.getImage($Image_7.java)
      at org.apache.tapestry.html.Image.renderComponent(Image.java:46)
      at org.apache.tapestry.AbstractComponent.render(AbstractComponent.java:712)
      at org.apache.tapestry.services.impl.DefaultResponseBuilder.render(DefaultResponseBuilder.java:184)
      at org.apache.tapestry.AbstractComponent.renderBody(AbstractComponent.java:525)
      at org.apache.tapestry.components.Any.renderComponent(Any.java:53)
      at org.apache.tapestry.AbstractComponent.render(AbstractComponent.java:712)
      at org.apache.tapestry.services.impl.DefaultResponseBuilder.render(DefaultResponseBuilder.java:184)
      at org.apache.tapestry.AbstractComponent.renderBody(AbstractComponent.java:525)
      at org.apache.tapestry.components.IfBean.renderComponent(IfBean.java:96)
      at org.apache.tapestry.AbstractComponent.render(AbstractComponent.java:712)
      at org.apache.tapestry.services.impl.DefaultResponseBuilder.render(DefaultResponseBuilder.java:184)
      at org.apache.tapestry.BaseComponent.renderComponent(BaseComponent.java:92)
      at org.apache.tapestry.AbstractComponent.render(AbstractComponent.java:712)
      at org.apache.tapestry.services.impl.DefaultResponseBuilder.render(DefaultResponseBuilder.java:184)
      at org.apache.tapestry.AbstractComponent.renderBody(AbstractComponent.java:525)
      at org.apache.tapestry.html.Body.renderComponent(Body.java:38)
      at org.apache.tapestry.AbstractComponent.render(AbstractComponent.java:712)
      at org.apache.tapestry.services.impl.DefaultResponseBuilder.render(DefaultResponseBuilder.java:184)
      at org.apache.tapestry.AbstractComponent.renderBody(AbstractComponent.java:525)
      at org.apache.tapestry.html.Shell.renderComponent(Shell.java:64)
      at org.apache.tapestry.AbstractComponent.render(AbstractComponent.java:712)
      at org.apache.tapestry.services.impl.DefaultResponseBuilder.render(DefaultResponseBuilder.java:184)
      at org.apache.tapestry.BaseComponent.renderComponent(BaseComponent.java:92)
      at org.apache.tapestry.AbstractComponent.render(AbstractComponent.java:712)
      at org.apache.tapestry.services.impl.DefaultResponseBuilder.render(DefaultResponseBuilder.java:184)
      at org.apache.tapestry.BaseComponent.renderComponent(BaseComponent.java:92)
      at org.apache.tapestry.AbstractComponent.render(AbstractComponent.java:712)
      at org.apache.tapestry.services.impl.DefaultResponseBuilder.render(DefaultResponseBuilder.java:182)
      at org.apache.tapestry.AbstractPage.renderPage(AbstractPage.java:237)
      at org.apache.tapestry.engine.RequestCycle.renderPage(RequestCycle.java:397)
      at org.apache.tapestry.services.impl.DefaultResponseBuilder.renderResponse(DefaultResponseBuilder.java:158)
      at org.apache.tapestry.services.impl.ResponseRendererImpl.renderResponse(ResponseRendererImpl.java:33)
      at $ResponseRenderer_111bc7a6929.renderResponse($ResponseRenderer_111bc7a6929.java)
      at org.apache.tapestry.engine.DirectService.service(DirectService.java:151)
      at $IEngineService_111bc7a69a8.service($IEngineService_111bc7a69a8.java)
      at org.apache.tapestry.services.impl.EngineServiceInnerProxy.service(EngineServiceInnerProxy.java:77)
      at org.apache.tapestry.services.impl.EngineServiceOuterProxy.service(EngineServiceOuterProxy.java:72)
      at org.apache.tapestry.engine.AbstractEngine.service(AbstractEngine.java:246)
      at org.apache.tapestry.services.impl.InvokeEngineTerminator.service(InvokeEngineTerminator.java:54)
      at $WebRequestServicer_111bc7a697f.service($WebRequestServicer_111bc7a697f.java)
      at $WebRequestServicer_111bc7a697b.service($WebRequestServicer_111bc7a697b.java)
      at org.apache.tapestry.services.impl.WebRequestServicerPipelineBridge.service(WebRequestServicerPipelineBridge.java:61)
      at $ServletRequestServicer_111bc7a6961.service($ServletRequestServicer_111bc7a6961.java)
      at org.apache.tapestry.request.DecodedRequestInjector.service(DecodedRequestInjector.java:55)
      at $ServletRequestServicerFilter_111bc7a695d.service($ServletRequestServicerFilter_111bc7a695d.java)
      at $ServletRequestServicer_111bc7a6963.service($ServletRequestServicer_111bc7a6963.java)
      at org.apache.tapestry.multipart.MultipartDecoderFilter.service(MultipartDecoderFilter.java:52)
      at $ServletRequestServicerFilter_111bc7a695b.service($ServletRequestServicerFilter_111bc7a695b.java)
      at $ServletRequestServicer_111bc7a6963.service($ServletRequestServicer_111bc7a6963.java)
      at org.apache.tapestry.services.impl.SetupRequestEncoding.service(SetupRequestEncoding.java:53)
      at $ServletRequestServicerFilter_111bc7a695f.service($ServletRequestServicerFilter_111bc7a695f.java)
      at $ServletRequestServicer_111bc7a6963.service($ServletRequestServicer_111bc7a6963.java)
      at $ServletRequestServicer_111bc7a6955.service($ServletRequestServicer_111bc7a6955.java)
      at org.apache.tapestry.ApplicationServlet.doService(ApplicationServlet.java:123)
      at org.apache.tapestry.ApplicationServlet.doGet(ApplicationServlet.java:104)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
      at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)
      at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:178)
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126)
      at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)
      at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107)
      at com.bmw.authenticator.extranet.catalina.ExtranetValve.invoke(ExtranetValve.java:171)
      at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
      at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:869)
      at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:664)
      at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527)
      at org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:80)
      at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684)
      at java.lang.Thread.run(Thread.java:619)
      Caused by: javassist.CannotCompileException: [source error] syntax error near "etAsset(.getMeldung("
      at javassist.CtBehavior.setBody(CtBehavior.java:347)
      at javassist.CtBehavior.setBody(CtBehavior.java:316)
      at org.apache.tapestry.enhance.ClassFabImpl.addMethod(ClassFabImpl.java:272)
      ... 82 more
      Caused by: compile error: syntax error near "etAsset(.getMeldung("
      at javassist.compiler.Parser.parsePrimaryExpr(Parser.java:1255)
      at javassist.compiler.Parser.parsePostfix(Parser.java:1029)
      at javassist.compiler.Parser.parseUnaryExpr(Parser.java:887)
      at javassist.compiler.Parser.parseBinaryExpr(Parser.java:774)
      at javassist.compiler.Parser.parseConditionalExpr(Parser.java:718)
      at javassist.compiler.Parser.parseExpression(Parser.java:698)
      at javassist.compiler.Parser.parseArgumentList(Parser.java:1329)
      at javassist.compiler.Parser.parseMethodCall(Parser.java:1177)
      at javassist.compiler.Parser.parsePostfix(Parser.java:1034)
      at javassist.compiler.Parser.parseCast(Parser.java:920)
      at javassist.compiler.Parser.parseUnaryExpr(Parser.java:885)
      at javassist.compiler.Parser.parseBinaryExpr(Parser.java:774)
      at javassist.compiler.Parser.parseConditionalExpr(Parser.java:718)
      at javassist.compiler.Parser.parseExpression(Parser.java:698)
      at javassist.compiler.Parser.parsePrimaryExpr(Parser.java:1243)
      at javassist.compiler.Parser.parsePostfix(Parser.java:1029)
      at javassist.compiler.Parser.parseCast(Parser.java:920)
      at javassist.compiler.Parser.parseUnaryExpr(Parser.java:885)
      at javassist.compiler.Parser.parseCast(Parser.java:917)
      at javassist.compiler.Parser.parseUnaryExpr(Parser.java:885)
      at javassist.compiler.Parser.parseBinaryExpr(Parser.java:774)
      at javassist.compiler.Parser.parseConditionalExpr(Parser.java:718)
      at javassist.compiler.Parser.parseExpression(Parser.java:698)
      at javassist.compiler.Parser.parseReturn(Parser.java:506)
      at javassist.compiler.Parser.parseStatement(Parser.java:268)
      at javassist.compiler.Parser.parseBlock(Parser.java:288)
      at javassist.compiler.Parser.parseStatement(Parser.java:242)
      at javassist.compiler.Javac.compileBody(Javac.java:203)
      at javassist.CtBehavior.setBody(CtBehavior.java:341)
      ... 84 more
      14:04:18,800 DEBUG ConversationManager:52 - BEGIN getCurrentConversation()

        Activity

        Mark Thomas made changes -
        Workflow Default workflow, editable Closed status [ 12566942 ] jira [ 12589705 ]
        Mark Thomas made changes -
        Workflow jira [ 12401178 ] Default workflow, editable Closed status [ 12566942 ]
        Jesse Kuhnert made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Assignee Jesse Kuhnert [ jkuhnert ]
        Resolution Fixed [ 1 ]
        Fix Version/s 4.1.2 [ 12312202 ]
        Jesse Kuhnert added a comment -

        Ughh I know, I just realized this yesterday. Stupid catch block mistake. I'll be fixing / pushing out a new tap update in a couple more hours.

        Marcus Schulte created issue -

          People

          • Assignee:
            Jesse Kuhnert
            Reporter:
            Marcus Schulte
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development