Tapestry
  1. Tapestry
  2. TAPESTRY-1247

When a div containing a DirectLink using a PopupLinkRenderer is updated asynchronously, the attached javascript portion of the ajax response is ignored.

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.1.1
    • Fix Version/s: 4.1.2
    • Labels:
      None
    • Environment:
      java 1.5.0_06, OSX 10.4.8, Firefox 2, Firefox 1.5
      java 1.5.0_08, WinXP SP2, FF2, IE 6

      Description

      There are many details at the following URL, including a sample program and source to illustrate the problem.

      http://jwoodchip.blogspot.com/2007/02/ajax-and-tapestry.html

      Just to summarize:

      1. create a page containing an asynchronous DirectLink, and direct it to update some div (testdiv)
      2. the listener for that DirectLink changes some data around
      3. testdiv references another component which uses that data to create some more DirectLinks, but these ones are synchronous and use org.apache.tapestry.contrib.link.PopupLinkRenderer for rendering

      In that scenario, none of the popup links (ie the synchronous DirectLinks) will work, because the javascript passed along with the ajax-response is never processed, and thus popup_window() is undefined.

      1. ajaxpop.zip
        344 kB
        Julian Wood

        Activity

        Julian Wood created issue -
        Julian Wood added a comment -

        This a sample project that can be built with maven to reproduce the issue.

        Julian Wood made changes -
        Field Original Value New Value
        Attachment ajaxpop.zip [ 12350232 ]
        Andreas Andreou added a comment -

        Already fixed this a few hours ago.

        Andreas Andreou made changes -
        Fix Version/s 4.1.2 [ 12312202 ]
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Assignee Andreas Andreou [ andyhot ]
        Julian Wood added a comment -

        Wow that is fast! Works perfectly now. Thanks!

        Mark Thomas made changes -
        Workflow jira [ 12395645 ] Default workflow, editable Closed status [ 12569214 ]
        Mark Thomas made changes -
        Workflow Default workflow, editable Closed status [ 12569214 ] jira [ 12590471 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        10m 5s 1 Andreas Andreou 02/Feb/07 17:55

          People

          • Assignee:
            Andreas Andreou
            Reporter:
            Julian Wood
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development