Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.1.1
    • Fix Version/s: 4.1.1
    • Component/s: tapestry-core
    • Labels:
      None
    • Environment:
      latest head

      Description

      I tried to do AJAX updates, the response is below.
      In IE6 an empty textarea is displayed correctly, but in FF1.5 the updated part will be incorrect, see the attached image.

      Regards,
      Norbi

      <ajax-response><response id="editorPanel" type="element"><div id="editorPanel">
      <span>
      <form method="post" action="/webapp/Topic,topicView.form.sdirect" id="form">
      <div style="display:none;" id="formhidden"><input type="hidden" name="formids" value="editor,save"/>
      <input type="hidden" name="submitmode" value=""/>
      <input type="hidden" name="submitname" value=""/>
      </div>
      <textarea name="editor"></textarea> <---------------------------- HERE
      <input type="submit" name="save" id="save"/>
      </form>
      </span>
      </div></response>

      1. jira.JPG
        4 kB
        Norbert Sándor

        Activity

        Andreas Andreou added a comment -

        Fixed by postprocessing tapestry.html.getContentAsString in FF case

        Andreas Andreou added a comment -

        This was also happenning in tacos

        The problem is that Mozilla's XML parser loads the xml
        as '<textarea/> but its html renderer dislikes this...

        See http://fisheye3.cenqua.com/browse/tacos/tacos-4.0/trunk/tacos-core/src/java/net/sf/tacos/ajax/components/tacos.js?r=413#l131
        for the fix, we simply get the ajax response (after FF loads it) and change all
        <textarea(.*?)/>
        into
        <textarea$1></textarea>

        Norbert Sándor added a comment -

        The attached image contains only the textarea with the corrupt content, not the entire page...

        Norbert Sándor added a comment -

        page after ajax update in FF1.5.0.7


          People

          • Assignee:
            Andreas Andreou
            Reporter:
            Norbert Sándor
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development