Tapestry
  1. Tapestry
  2. TAPESTRY-1110

Asynchronious link with disable=true generates errors

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.1.1
    • Fix Version/s: 4.1.1
    • Component/s: tapestry-core
    • Labels:
      None
    • Environment:
      Tapestry 4.1.1 SNAPSHOT

      Description

      If a DirectLink with async=true also have a disabled=true then link is not generated but async handler is still trying to be associated with it which leads to error:

      FATAL exception raised: bad srcObj for srcFunc: onclick

      The problem is obilivious and should be fairy easy to fix.

        Activity

        Mark Thomas made changes -
        Workflow Default workflow, editable Closed status [ 12567906 ] jira [ 12591033 ]
        Mark Thomas made changes -
        Workflow jira [ 12386284 ] Default workflow, editable Closed status [ 12567906 ]
        Jesse Kuhnert made changes -
        Resolution Fixed [ 1 ]
        Status Open [ 1 ] Resolved [ 5 ]
        Fix Version/s 4.1.1 [ 12312021 ]
        Jesse Kuhnert added a comment -

        Yep - it was easy. Thanks for reporting it.

        Jesse Kuhnert made changes -
        Field Original Value New Value
        Assignee Jesse Kuhnert [ jkuhnert ]
        Renat Zubairov created issue -

          People

          • Assignee:
            Jesse Kuhnert
            Reporter:
            Renat Zubairov
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development