Tapestry
  1. Tapestry
  2. TAPESTRY-1096

FieldLabel+EventListener breaks Checkbox value

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.1.1
    • Fix Version/s: 4.1.1
    • Component/s: Framework
    • Labels:
      None
    • Environment:
      WinXP SP2; Tomcat 5.5

      Description

      When an EventListener submits a form with a checkbox in it, if the checkbox has a field label attached to it, it seems to rewind the form twice and set the checkbox's value to false on the second rewind.

      I have attached files that should demonstrate this.

      1. TestPage.html
        0.5 kB
        Peter Beshai
      2. TestPage.java
        1.0 kB
        Peter Beshai

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        82d 8h 10m 1 Jesse Kuhnert 13/Dec/06 04:06
        Mark Thomas made changes -
        Workflow Default workflow, editable Closed status [ 12567884 ] jira [ 12591012 ]
        Mark Thomas made changes -
        Workflow jira [ 12384232 ] Default workflow, editable Closed status [ 12567884 ]
        Jesse Kuhnert made changes -
        Resolution Fixed [ 1 ]
        Status Open [ 1 ] Resolved [ 5 ]
        Jesse Kuhnert added a comment -

        Right. Resolving for now as the documentation does state why/how this should work this way.

        Still - the FieldLabel component has all kinds of issues and this shouldn't be something someone has to think about.

        Jesse Kuhnert made changes -
        Fix Version/s 4.1.1 [ 12312021 ]
        Peter Beshai added a comment -

        Maybe this is caused by not setting prerender="false" on the FieldLabel (since it comes after the checkbox).

        Jesse Kuhnert made changes -
        Assignee Jesse Kuhnert [ jkuhnert ]
        Peter Beshai made changes -
        Attachment TestPage.html [ 12341321 ]
        Peter Beshai made changes -
        Field Original Value New Value
        Attachment TestPage.java [ 12341320 ]
        Peter Beshai created issue -

          People

          • Assignee:
            Jesse Kuhnert
            Reporter:
            Peter Beshai
          • Votes:
            1 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development