You end up with methods like onValidateFormFromLogin() which is just asking for trouble.
onFormValidateFromLogin() is a bit better.
Obviously, we keep the old name as well ... have to fire two events at the validate form stage.
What would be a better name? Something that doesn't have "form" is it; perhaps "finalValidation" or just "validate". I remember this was a problem with calling it "validate" before, because this conflicted with the validate event form form control element components ... but is that really a problem?
|Field||Original Value||New Value|
|Assignee||Howard M. Lewis Ship [ hlship ]|
|Summary||The Form event "validateForm" is awkward, a new name (perhaps "formValidate") would be nice||The Form event "validateForm" is awkward, just "validate" should do|
|Status||Open [ 1 ]||In Progress [ 3 ]|
|Summary||The Form event "validateForm" is awkward, just "validate" should do||The Form event "validateForm" is awkwardly named and should be replaced with the simpler name "validate"|
|Status||In Progress [ 3 ]||Closed [ 6 ]|
|Fix Version/s||5.2.0 [ 12314122 ]|
|Resolution||Fixed [ 1 ]|
|Transition||Time In Source Status||Execution Times||Last Executer||Last Execution Date|
|196d 7h 20m||1||Howard M. Lewis Ship||13/Jan/10 01:36|
|43m 10s||1||Howard M. Lewis Ship||13/Jan/10 02:19|