Tapestry 5
  1. Tapestry 5
  2. TAP5-724

Tapestry generates invalid HTML (for strict and transitional doctypes)

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 5.1.0.5
    • Fix Version/s: 5.3
    • Component/s: None
    • Labels:
      None

      Description

      As http://validator.w3.org/check tells, HTML documents generated from Tapestry are invalid. xHTMLs are valid.

      I.e. using

      <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">

      or

      <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">

      leads to invalid documents.

      The errors are:

      • Attribute "XMLNS" is not a valid attribute.

      ...<html xmlns="http://www.w3.org/1999/xhtml">

      • end tag for element "LINK" which is not open

      ...tapestry/5.1.0.5/default.css"></link><link type="text/css" rel="stylesheet" h

      • end tag for element "META" which is not open

      ...on 5.1.0.5)" name="generator"></meta></head>

        Activity

        Sergey Didenko created issue -
        Howard M. Lewis Ship made changes -
        Field Original Value New Value
        Summary tapestry generates invalid HTML, strict and transitional Tapestry generates invalid HTML (for strict and transitional doctypes)
        Howard M. Lewis Ship made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Assignee Howard M. Lewis Ship [ hlship ]
        Fix Version/s 5.3 [ 12316024 ]
        Resolution Fixed [ 1 ]
        Hudson added a comment -

        Integrated in tapestry-trunk-freestyle #580 (See https://builds.apache.org/job/tapestry-trunk-freestyle/580/)
        TAP5-724: Tapestry generates invalid HTML (for strict and transitional doctypes)

        hlship : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1185431
        Files :

        • /tapestry/tapestry5/trunk/tapestry-core/src/main/java/org/apache/tapestry5/dom/DefaultMarkupModel.java
        • /tapestry/tapestry5/trunk/tapestry-core/src/test/resources/org/apache/tapestry5/internal/services/added_scripts_go_before_existing_script.txt
        • /tapestry/tapestry5/trunk/tapestry-core/src/test/resources/org/apache/tapestry5/internal/services/ie_conditional_stylesheet.txt
        • /tapestry/tapestry5/trunk/tapestry-core/src/test/resources/org/apache/tapestry5/internal/services/immediate_initialization.txt
        • /tapestry/tapestry5/trunk/tapestry-core/src/test/resources/org/apache/tapestry5/internal/services/other_initialization.txt
        • /tapestry/tapestry5/trunk/tapestry-core/src/test/resources/org/apache/tapestry5/internal/services/pretty_print_initialization.txt
        Howard M. Lewis Ship made changes -
        Resolution Fixed [ 1 ]
        Status Closed [ 6 ] Reopened [ 4 ]
        Howard M. Lewis Ship added a comment -

        I've reverted this fix and will close the issue without fixing. Basically, as soon as I put this into use on an existing app, the page layout got completely screwed. Apparently, browsers prefer their markup broken. You can use meta-data to force Tapestry to use the XML (not HTML) renderer, by setting the page content type.

        Howard M. Lewis Ship made changes -
        Status Reopened [ 4 ] Closed [ 6 ]
        Fix Version/s 5.3 [ 12316024 ]
        Resolution Won't Fix [ 2 ]
        Hudson added a comment -

        Integrated in tapestry-trunk-freestyle #583 (See https://builds.apache.org/job/tapestry-trunk-freestyle/583/)
        Revert "TAP5-724: Tapestry generates invalid HTML (for strict and transitional doctypes)"

        This reverts commit 53ed2911464dafe16b26e7776883091cebf27430.

        hlship : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1185891
        Files :

        • /tapestry/tapestry5/trunk/tapestry-core/src/main/java/org/apache/tapestry5/dom/DefaultMarkupModel.java
        • /tapestry/tapestry5/trunk/tapestry-core/src/test/resources/org/apache/tapestry5/internal/services/added_scripts_go_before_existing_script.txt
        • /tapestry/tapestry5/trunk/tapestry-core/src/test/resources/org/apache/tapestry5/internal/services/ie_conditional_stylesheet.txt
        • /tapestry/tapestry5/trunk/tapestry-core/src/test/resources/org/apache/tapestry5/internal/services/immediate_initialization.txt
        • /tapestry/tapestry5/trunk/tapestry-core/src/test/resources/org/apache/tapestry5/internal/services/other_initialization.txt
        • /tapestry/tapestry5/trunk/tapestry-core/src/test/resources/org/apache/tapestry5/internal/services/pretty_print_initialization.txt
        Howard M. Lewis Ship made changes -
        Resolution Won't Fix [ 2 ]
        Status Closed [ 6 ] Reopened [ 4 ]
        Howard M. Lewis Ship added a comment -

        Sorry for the thrashing ... the actual bug was caused by Form no longer supporting informal parameters. That's fixed and the corrected HTML markup output is revealed to not be the cause of the layout problems I was seeing. Jumped the gun ... this is fixed in 5.3-beta-24.

        Howard M. Lewis Ship made changes -
        Status Reopened [ 4 ] Closed [ 6 ]
        Fix Version/s 5.3 [ 12316024 ]
        Resolution Fixed [ 1 ]
        Hudson added a comment -

        Integrated in tapestry-trunk-freestyle #584 (See https://builds.apache.org/job/tapestry-trunk-freestyle/584/)
        TAP5-724: Restore informal parameters support to Form component
        TAP5-724: Tapestry generates invalid HTML (for strict and transitional doctypes)

        hlship : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1185914
        Files :

        • /tapestry/tapestry5/trunk/tapestry-core/src/main/java/org/apache/tapestry5/corelib/components/Form.java

        hlship : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1185913
        Files :

        • /tapestry/tapestry5/trunk/tapestry-core/src/main/java/org/apache/tapestry5/dom/DefaultMarkupModel.java
        • /tapestry/tapestry5/trunk/tapestry-core/src/test/resources/org/apache/tapestry5/internal/services/added_scripts_go_before_existing_script.txt
        • /tapestry/tapestry5/trunk/tapestry-core/src/test/resources/org/apache/tapestry5/internal/services/ie_conditional_stylesheet.txt
        • /tapestry/tapestry5/trunk/tapestry-core/src/test/resources/org/apache/tapestry5/internal/services/immediate_initialization.txt
        • /tapestry/tapestry5/trunk/tapestry-core/src/test/resources/org/apache/tapestry5/internal/services/other_initialization.txt
        • /tapestry/tapestry5/trunk/tapestry-core/src/test/resources/org/apache/tapestry5/internal/services/pretty_print_initialization.txt
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        873d 3h 18m 1 Howard M. Lewis Ship 18/Oct/11 00:24
        Closed Closed Reopened Reopened
        23h 30m 2 Howard M. Lewis Ship 18/Oct/11 23:56
        Reopened Reopened Closed Closed
        2m 9s 2 Howard M. Lewis Ship 18/Oct/11 23:57

          People

          • Assignee:
            Howard M. Lewis Ship
            Reporter:
            Sergey Didenko
          • Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development