Tapestry 5
  1. Tapestry 5
  2. TAP5-707

Yellow highlight remains on updated zone if zone is re-updated too quickly

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 5.2, 5.1.0.5
    • Fix Version/s: 5.2.0, 5.1.0.8
    • Component/s: tapestry-core
    • Labels:
      None

      Description

      By default when a zone updates it shows a yellow highlight that fades away. However, if the zone is updated before the highlight has completely faded then the highlight remains (until the page is completely refreshed).

      To see this in action, go to the JumpStart demo application:
      http://jumpstart.doublenegative.com.au:8080/jumpstart/examples/javascript/ajax

      And double-click the link "Refresh time2 only - this is an AJAX-enabled ActionLink".

      (Although JumpStart is currently based on T5.0.18 we see the same behaviour on T5.1.0.5)

        Activity

        Lenny Primak added a comment -

        The FlowLogix tapestry library will contain a fix for this bug in the next release. (1.2.3)
        which will go out sometime in the next week or so.

        Ref: FlowLogix Issue http://code.google.com/p/flowlogix/issues/detail?id=43
        This is already available as a snapshot release

        Ulrich Stärk added a comment -

        It also happens in 5.2.0-SNAPSHOT.

        The problem is the way the highlight effect determines it's end color:

        From effects.js, lines 498 and 499:

        if (!this.options.endcolor)
        this.options.endcolor = this.element.getStyle('background-color').parseColor('#ffffff');

        The end color is the color of the element to fade or white if that can't be parsed. Since the endcolor is determined while the fade effect is still running, it is some variation of yellow. A solution could be to determine the endcolor on page load and set an explicit end color for the hilight effect to use.


          People

          • Assignee:
            Ulrich Stärk
            Reporter:
            Paul Field
          • Votes:
            2 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development