Tapestry 5
  1. Tapestry 5
  2. TAP5-1788

Service id 'environment' has already been defined by org.apache.tapestry5.services.TapestryModule with Spring 3.1

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 5.2.4
    • Fix Version/s: 5.3.2, 5.4
    • Component/s: tapestry-spring
    • Labels:
      None

      Description

      After upgrading to Spring 3.1, started seeing the following error with Tapestry 5.2.4.

      java.lang.RuntimeException: Service id 'environment' has already been defined by org.apache.tapestry5.services.TapestryModule.buildEnvironment(PerthreadManager)

      More information at http://tapestry.1045711.n5.nabble.com/tapestry-5-2-4-and-spring-3-1M1-td4462226.html#a4742011

        Issue Links

          Activity

            People

            • Assignee:
              Igor Drobiazko
              Reporter:
              Matt Raible
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development