Tapestry 5
  1. Tapestry 5
  2. TAP5-1422

java.util.ConcurrentModificationException when shutting down jmx server

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 5.2.0
    • Fix Version/s: 5.3
    • Component/s: tapestry-jmx
    • Labels:
      None

      Description

      In MBeanSupportImpl the registryDidShutdown handler tries to remove items from a set that it's iterating over causing the exception.

        Activity

        Hudson added a comment -

        Integrated in tapestry-5.2-freestyle #260 (See https://hudson.apache.org/hudson/job/tapestry-5.2-freestyle/260/)
        Fix for TAP5-1422 - pulled the registeredBeans into another data structure to iterate over so we can remove them from the set.

        Josh Canfield added a comment -

        Sorry, this wasn't a very good defect report. The issue is with the MBeanSupportImpl in the jmx package The code above grabs an iterator and then removes items from the underlying set.

        We'll probably see other errors if the registered beans depend on services.

        Howard M. Lewis Ship added a comment -

        I believe I added another issue w.r.t. having mulitple phases of shutdown; this unregistering belongs in the early phase (before proxies are deactivated, which should happen last).


          People

          • Assignee:
            Josh Canfield
            Reporter:
            Josh Canfield
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development