Tapestry 5
  1. Tapestry 5
  2. TAP5-1261

Tapestry adds event handlers not only to form components, but also to simple forms

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 5.2.0
    • Fix Version/s: 5.2.1
    • Component/s: tapestry-core
    • Labels:
      None

      Description

      After upgrading to Tapestry 5.2.0 I experienced an Javascript error upon submitting a form. It's a plain form defined in the template, not a Form component.

      The error is:
      tapestry.js, line 1462: 'undefined' is null or not an object

      This happened in IE8. It's reproducible with and without enabling IE7 compatible mode. A user on the mailing list suggested that he saw similar error messages in his FF console.

      I saw this for the forst time after upgrading to Tapestry 5.2.0.

      I would expect, Tapestry not interacting with a form in the template, as long as it's plain markup and not a form component.

        Activity

        Andreas Andreou added a comment -

        Yep, the error is:
        Error: firstHidden is undefined
        Source File: http://127.0.0.1:8080/tapestwitter/assets/1.0-SNAPSHOT/tapestry/tapestry.js
        Line: 1462

        and happens because tapestry assumes there are always inputs with type="hidden" in forms.
        That's true for tapestry forms, but not always the case with manual forms

        Hudson added a comment -

        Integrated in tapestry-5.2-freestyle #181 (See https://hudson.apache.org/hudson/job/tapestry-5.2-freestyle/181/)
        fixes TAP5-1261

        Jochen Kemnade added a comment -

        This issue has come back in Tapestry 5.4.


          People

          • Assignee:
            Andreas Andreou
            Reporter:
            Andy Pahne
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development