Tapestry 5
  1. Tapestry 5
  2. TAP5-1246

Tapestry should use SQLException.getNextException() to dig down to the "root cause"

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 5.2.1
    • Fix Version/s: 5.2.1
    • Component/s: tapestry-core
    • Labels:
      None

      Description

      SQLException includes a nextException property, but often does not set the JDK cause property. Tapestry should generalize, and use as the cause whatever property of type Throwable is not null.

        Activity

        Howard M. Lewis Ship created issue -
        Howard M. Lewis Ship added a comment -

        This can be annoying, because the exception report stops short of where the really useful detail goes.

        Howard M. Lewis Ship made changes -
        Field Original Value New Value
        Assignee Howard M. Lewis Ship [ hlship ]
        Howard M. Lewis Ship made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Fix Version/s 5.2.1 [ 12315230 ]
        Resolution Fixed [ 1 ]
        Hudson added a comment -

        Integrated in tapestry-5.2-freestyle #174 (See https://hudson.apache.org/hudson/job/tapestry-5.2-freestyle/174/)
        TAP5-1246: Tapestry should use SQLException.getNextException() to dig down to the "root cause"

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        1d 18h 20m 1 Howard M. Lewis Ship 18/Aug/10 17:54

          People

          • Assignee:
            Howard M. Lewis Ship
            Reporter:
            Howard M. Lewis Ship
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development