Uploaded image for project: 'Tamaya'
  1. Tamaya
  2. TAMAYA-287

Maven warning in site build - wrong usage of enforcer plugin

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 0.3-incubating
    • Fix Version/s: 0.4-incubating
    • Component/s: Infrastructure
    • Labels:
      None

      Description

      If I run the goal
      $ mvn site
      on release-0.3 I get:

      21:10 $ mvn site
      [INFO] Scanning for projects...
      [WARNING] The project org.apache.tamaya:tamaya-all:pom:0.3-incubating uses prerequisites which is only intended for maven-plugin projects but not for non maven-plugin projects. For such purposes you should use the maven-enforcer-plugin. See https://maven.apache.org/enforcer/enforcer-rules/requireMavenVersion.html
      

      with mvn 3.5.0.

      Maybe this can be fixed in master as well.

        Attachments

          Activity

            People

            • Assignee:
              pottlinger Philipp Ottlinger
              Reporter:
              pottlinger Philipp Ottlinger
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: