Uploaded image for project: 'Tajo'
  1. Tajo
  2. TAJO-930

Could not initialize class org.apache.tajo.QueryTestCaseBase during building

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Trivial
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: 0.10.0
    • Component/s: None
    • Labels:
    • Environment:

      CentOS 6.4, Eclipse Kepler SR2, and Apache Maven 3.2.1
      Trying to Build as a "mvn clean install" command

      Description

      Bunch of errors are occured when I try to build tajo as a "mvn clean install."

      Please check the description in detail.
      I believe that it is good for us to check either below errors are shown or not in other environments.

      --------------------------------------------------------------------------------------
      Results :

      Tests in error:
      org.apache.tajo.benchmark.TestTPCH
      org.apache.tajo.benchmark.TestTPCH: Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.engine.function.TestBuiltinFunctions: Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.engine.function.TestBuiltinFunctions: Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.engine.query.TestCTASQuery: Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.engine.query.TestCTASQuery: Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.engine.query.TestJoinOnPartitionedTables: Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.engine.query.TestJoinOnPartitionedTables: Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.engine.query.TestNetTypes: Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.engine.query.TestNetTypes: Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.engine.query.TestCreateTable: Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.engine.query.TestCreateTable: Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.engine.query.TestInsertQuery: Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.engine.query.TestInsertQuery: Could not initialize class org.apache.tajo.QueryTestCaseBase
      initializationError(org.apache.tajo.engine.query.TestJoinQuery): Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.engine.query.TestCreateDatabase: Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.engine.query.TestCreateDatabase: Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.engine.query.TestWindowQuery: Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.engine.query.TestWindowQuery: Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.engine.query.TestDropTable: Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.engine.query.TestDropTable: Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.engine.query.TestAlterTablespace: Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.engine.query.TestAlterTablespace: Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.engine.query.TestTruncateTable: Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.engine.query.TestTruncateTable: Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.engine.query.TestTablePartitions: Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.engine.query.TestTablePartitions: Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.engine.query.TestSelectQuery: Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.engine.query.TestSelectQuery: Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.engine.query.TestCaseByCases: Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.engine.query.TestCaseByCases: Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.engine.query.TestTableSubQuery: Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.engine.query.TestTableSubQuery: Could not initialize class org.apache.tajo.QueryTestCaseBase
      testIsNotNull(org.apache.tajo.engine.query.TestNullValues)
      testResultSetNull(org.apache.tajo.engine.query.TestNullValues)
      testResultSetNullSimpleQuery(org.apache.tajo.engine.query.TestNullValues)
      testIsNotNull2(org.apache.tajo.engine.query.TestNullValues)
      testIsNotNull3(org.apache.tajo.engine.query.TestNullValues)
      testIsNull(org.apache.tajo.engine.query.TestNullValues)
      org.apache.tajo.engine.query.TestUnionQuery: Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.engine.query.TestUnionQuery: Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.engine.query.TestAlterTable: Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.engine.query.TestAlterTable: Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.engine.query.TestGroupByQuery: Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.engine.query.TestGroupByQuery: Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.engine.query.TestJoinBroadcast: Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.engine.query.TestJoinBroadcast: Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.engine.query.TestSortQuery: Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.engine.query.TestSortQuery: Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.engine.planner.physical.TestSortExec
      testInsertOverwriteIntoLocation(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testCreateTable1(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testCreateTable2(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testCreateTable3(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testCreateTable4(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testCreateTable5(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testCreateTable6(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testCreateTable7(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testCreateTable8(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testCreateTable9(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testCreateTable10(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testInsertOverwriteIntoTable(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testAsterisk1(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testAsterisk2(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testAsterisk3(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testAsterisk4(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testInsertIntoTable(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testJoin1(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testJoin2(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testJoin3(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testJoin4(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testJoin5(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testJoin6(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testJoin7(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testJoin8(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testJoin9(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testSet1(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testSet2(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testSet3(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testSet4(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testExistsPredicate1(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testExistsPredicate2(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testCreateTableLike1(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testTableSubQuery1(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testTableSubQuery2(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testInsertIntoLocation(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testCreateTablePartitionByList(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testInsertOverwriteIntoTable2(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testCreateTablePartitionByColumn(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testDropTable(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testGroupby1(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testInsertIntoTable2(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testJoin10(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testJoin11(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testCreateTablePartitionByHash1(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testCreateTablePartitionByHash2(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testCreateTablePartitionByRange(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testSelect1(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testSelect2(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testSelect3(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testSelect4(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testSelect5(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testInSubquery1(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      testInSubquery2(org.apache.tajo.engine.parser.TestSQLAnalyzer)
      test(org.apache.tajo.storage.TestRowFile): Mkdirs failed to create /test
      org.apache.tajo.master.querymaster.TestQueryUnitStatusUpdate: Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.master.querymaster.TestQueryUnitStatusUpdate: Could not initialize class org.apache.tajo.QueryTestCaseBase
      testKillScheduledQuery(org.apache.tajo.scheduler.TestFifoScheduler): Giving up after tries=2
      testScheduledQuery(org.apache.tajo.scheduler.TestFifoScheduler): Giving up after tries=2
      testForwardedQuery(org.apache.tajo.scheduler.TestFifoScheduler): Giving up after tries=2
      org.apache.tajo.jdbc.TestTajoDatabaseMetaData: Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.jdbc.TestTajoDatabaseMetaData: Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.jdbc.TestResultSet: Error: file:/tmp/tajo-rony/warehouse/score/score alreay exists
      org.apache.tajo.jdbc.TestTajoJdbc: Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.jdbc.TestTajoJdbc: Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.jdbc.TestTajoJdbc: Could not initialize class org.apache.tajo.QueryTestCaseBase
      testCommand(org.apache.tajo.cli.TestExecExternalShellCommand): Giving up after tries=2
      testSelectResultWithNullTrue(org.apache.tajo.cli.TestTajoCli): Giving up after tries=2
      testStopWhenError(org.apache.tajo.cli.TestTajoCli): Giving up after tries=2
      testParseConf(org.apache.tajo.cli.TestTajoCli): Giving up after tries=2
      testLocalQueryWithoutFrom(org.apache.tajo.cli.TestTajoCli): Giving up after tries=2
      testConnectDatabase(org.apache.tajo.cli.TestTajoCli): Giving up after tries=2
      testSelectResultWithNullFalse(org.apache.tajo.cli.TestTajoCli): Giving up after tries=2
      testDescTable(org.apache.tajo.cli.TestTajoCli): Giving up after tries=2
      testHdfCommand(org.apache.tajo.cli.TestHdfsCommand): Giving up after tries=2
      testCreateAndDropDatabases(org.apache.tajo.client.TestTajoClient): Giving up after tries=2
      testCreateAndPurgeExternalTableByExecuteQuery(org.apache.tajo.client.TestTajoClient): Giving up after tries=2
      testCreateAndDropTableByExecuteQuery(org.apache.tajo.client.TestTajoClient): Giving up after tries=2
      testCreateAndPurgeTableByExecuteQuery(org.apache.tajo.client.TestTajoClient): Giving up after tries=2
      testUpdateQuery(org.apache.tajo.client.TestTajoClient): Giving up after tries=2
      testGetTableDesc(org.apache.tajo.client.TestTajoClient): Giving up after tries=2
      testGetTableList(org.apache.tajo.client.TestTajoClient): Giving up after tries=2
      testKillQuery(org.apache.tajo.client.TestTajoClient): Giving up after tries=2
      testSetCvsNull(org.apache.tajo.client.TestTajoClient): Giving up after tries=2
      testCreateAndPurgeExternalTable(org.apache.tajo.client.TestTajoClient): Giving up after tries=2
      testDropCurrentDatabase(org.apache.tajo.client.TestTajoClient): Giving up after tries=2
      testCurrentDatabase(org.apache.tajo.client.TestTajoClient): Giving up after tries=2
      testSelectDatabaseToInvalidOne(org.apache.tajo.client.TestTajoClient): Giving up after tries=2
      testGetQueryStatusAndResultAfterFinish(org.apache.tajo.client.TestTajoClient): Giving up after tries=2
      testCreateAndDropTablePartitionedColumnByExecuteQuery(org.apache.tajo.client.TestTajoClient): Giving up after tries=2
      testGetFunctions(org.apache.tajo.client.TestTajoClient)
      testCreateAndDropExternalTableByExecuteQuery(org.apache.tajo.client.TestTajoClient): Giving up after tries=2
      testDDLByExecuteQuery(org.apache.tajo.client.TestTajoClient): Giving up after tries=2
      testSessionVariables(org.apache.tajo.client.TestTajoClient): Giving up after tries=2
      testGetFinishedQueryList(org.apache.tajo.client.TestTajoClient): Giving up after tries=2
      testCreateAndDropExternalTable(org.apache.tajo.client.TestTajoClient): Giving up after tries=2
      testFailCreateTablePartitionedOtherExceptColumn(org.apache.tajo.client.TestTajoClient): Giving up after tries=2
      org.apache.tajo.client.TestTajoDump: Could not initialize class org.apache.tajo.QueryTestCaseBase
      org.apache.tajo.client.TestTajoDump: Could not initialize class org.apache.tajo.QueryTestCaseBase
      testTaskHistory(org.apache.tajo.worker.TestHistory)
      testTaskRunnerHistory(org.apache.tajo.worker.TestHistory)

        Activity

        blrunner Jaehwa Jung added a comment -

        Hi Yoonmin Nam

        Thanks for your reporting.
        But I closed this issue, because I can't reproduce it.
        If you find this bug again, could you open this issue again?

        Cheers
        Jaehwa


          People

          • Assignee:
            Unassigned
            Reporter:
            ronymin Yoonmin Nam
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development