Uploaded image for project: 'Tajo'
  1. Tajo
  2. TAJO-800

CLI's meta command should be aware "TABLE_NAME" style.

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.9.0
    • Component/s: None
    • Labels:
      None

      Description

      See title. Currently the following meta command will not work as intended.

      default> create database 'TEST';
      default> \c "TEST";
      No Database Found
      default> \c TEST;
      You are now connected to database "TEST" as user "babokim".
      
      1. TAJO-800_2.patch
        9 kB
        Hyunsik Choi
      2. TAJO-800.patch
        7 kB
        Hyoungjun Kim

        Activity

        hudson Hudson added a comment -

        FAILURE: Integrated in Tajo-master-build #214 (See https://builds.apache.org/job/Tajo-master-build/214/)
        TAJO-800: CLI's meta command should be aware "TABLE_NAME" style. (Hyoungjun Kim via hyunsik) (hyunsik: rev eb4e54a14a0f62749c4163d7192bdd547bc64e12)

        • tajo-client/src/main/java/org/apache/tajo/cli/TajoCli.java
        • tajo-client/src/main/java/org/apache/tajo/cli/DescTableCommand.java
        • tajo-core/src/test/resources/results/TestTajoCli/testDescTable.result
        • CHANGES
        • tajo-client/src/main/java/org/apache/tajo/cli/ConnectDatabaseCommand.java
        • tajo-core/src/test/java/org/apache/tajo/cli/TestTajoCli.java
        hyunsik Hyunsik Choi added a comment -

        committed it to master branch.

        hyunsik Hyunsik Choi added a comment -

        +1

        The bug fix looks reasonable, and it includes enough unit tests. The patch looks good to me.

        But, some added unit tests is failed when I test mvn -Dtajo.catalog.store.class=org.apache.tajo.catalog.store.HCatalogStore. This is because the metastore of Hive 0.12 does not support qualified identifier. So, I changed them to pass all unit tests. I've uploaded the fixed patch.

        I'll commit it shortly. Thanks!


          People

          • Assignee:
            hjkim Hyoungjun Kim
            Reporter:
            hjkim Hyoungjun Kim
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development