Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 0.8.0, 0.9.0
    • Fix Version/s: 0.8.0, 0.9.0
    • Component/s: Planner/Optimizer
    • Labels:
      None

      Description

      When I tested sub-queries for TPC-DS Q32, I found a bug about BroadCastJoin as follows:

      SQL

      SELECT COUNT(*)
      FROM (
        SELECT cs.cs_item_sk as cs_item_sk,
        cs.cs_ext_discount_amt as cs_ext_discount_amt
        FROM catalog_sales cs
        JOIN date_dim d ON (d.d_date_sk = cs.cs_sold_date_sk)
        WHERE d.d_date between '2000-01-27' and '2000-04-27'
      ) cs1
      JOIN item i ON (i.i_item_sk = cs1.cs_item_sk);
      

      tajo.dist-query.join.broadcast.auto = false

      result: 1 rows (8 B)
      ?count
      -------------------------------
      4163848
      

      tajo.dist-query.join.broadcast.auto = true

      result: 1 rows (8 B)
      ?count
      -------------------------------
      4139958
      

        Issue Links

          Activity

          blrunner Jaehwa Jung added a comment -

          We can't reproduce this bug any more.


            People

            • Assignee:
              blrunner Jaehwa Jung
              Reporter:
              blrunner Jaehwa Jung
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development