Uploaded image for project: 'Tajo'
  1. Tajo
  2. TAJO-445

testCastWithNestedFunctions causes unit test failure

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Trivial
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: 0.8.0
    • Component/s: Expression
    • Labels:
      None

      Description

      The direct comparison timestamp value and string in testSimpleEval can be failed in some JVMs. This patch fixes the unit test failure.

      Results :
      
      Failed tests:   testCastWithNestedFunction(org.apache.tajo.engine.eval.TestSQLExpression): select to_timestamp(CAST(split_part('1386577650.123', '.', 1) as INT8)); expected:<1970-01-17 [10]:09:37> but was:<1970-01-17 [01]:09:37>
      
      1. TAJO-445.patch
        0.9 kB
        Hyunsik Choi

        Activity

        hyunsik Hyunsik Choi added a comment -

        I misunderstood this problem. This problem is caused by timezone. I'll submit new patch soon.

        hyunsik Hyunsik Choi added a comment -

        This bug was fixed by TAJO-448.


          People

          • Assignee:
            hyunsik Hyunsik Choi
            Reporter:
            hyunsik Hyunsik Choi
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development