Uploaded image for project: 'Tajo'
  1. Tajo
  2. TAJO-1636

query rest api uri should change from /databases/{database_name}/queies to /queries

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.11.0
    • Component/s: None
    • Labels:
      None

      Description

      currently, "databases" Rest Api uri has too many meaning.
      1. for query
      2. to manage databases info
      and databases/

      {database_name}/queries is not proper for queries

      so I suggest change from "/databases/{database_name}

      /queries" to
      "/queries/", it is more clear to understand.

      below apis will changed.
      POST /databases/

      {databaseName}/queries -> POST /queries
      GET /databases/{databaseName}

      /queries -> GET /queries
      GET /databases/

      {databaseName}/queries/{queryId} -> GET /queries/{queryId}
      GET /databases/{databaseName}

      /queries/

      {queryId}/result -> GET /queries/{queryId}

      /result
      GET /databases/

      {databaseName}

      /queries/

      {queryId}/result/{cacheId} -> GET /queries/{queryId}

      /result/

      {cacheId}

        Activity

        hudson Hudson added a comment -

        SUCCESS: Integrated in Tajo-master-build #729 (See https://builds.apache.org/job/Tajo-master-build/729/)
        TAJO-1636: query rest api uri should change from /databases/

        {database_name}

        /queies to /queries. (blrunner: rev dc4904987dc16164dca4ff37c1178698537201c6)

        • tajo-core/src/main/java/org/apache/tajo/ws/rs/resources/QueryResource.java
        • CHANGES
        • tajo-core/src/test/java/org/apache/tajo/ws/rs/resources/TestQueryResource.java
        • tajo-core/src/test/java/org/apache/tajo/ws/rs/resources/TestQueryResultResource.java
        • tajo-core/src/main/java/org/apache/tajo/ws/rs/resources/QueryResultResource.java
        hudson Hudson added a comment -

        ABORTED: Integrated in Tajo-master-CODEGEN-build #368 (See https://builds.apache.org/job/Tajo-master-CODEGEN-build/368/)
        TAJO-1636: query rest api uri should change from /databases/

        {database_name}

        /queies to /queries. (blrunner: rev dc4904987dc16164dca4ff37c1178698537201c6)

        • tajo-core/src/main/java/org/apache/tajo/ws/rs/resources/QueryResultResource.java
        • tajo-core/src/main/java/org/apache/tajo/ws/rs/resources/QueryResource.java
        • tajo-core/src/test/java/org/apache/tajo/ws/rs/resources/TestQueryResultResource.java
        • CHANGES
        • tajo-core/src/test/java/org/apache/tajo/ws/rs/resources/TestQueryResource.java
        blrunner Jaehwa Jung added a comment -

        Thanks DaeMyung Kang.
        I've just committed it the master branch.

        githubbot ASF GitHub Bot added a comment -

        Github user asfgit closed the pull request at:

        https://github.com/apache/tajo/pull/598

        githubbot ASF GitHub Bot added a comment -

        Github user blrunner commented on the pull request:

        https://github.com/apache/tajo/pull/598#issuecomment-111690988

        Sorry, @charsyam .

        I think it would be a problem on my laptop.
        Currently, all unit test cases finished successfully.
        I'll push it soon.

        githubbot ASF GitHub Bot added a comment -

        Github user blrunner commented on the pull request:

        https://github.com/apache/tajo/pull/598#issuecomment-110729915

        @charsyam

        Could you check unit test cases for this patch?
        I failed to run test cases as following

        ```
        2015-06-10 21:24:15,646 WARN: io.netty.util.concurrent.DefaultPromise (warn(462)) - An exception was thrown by org.apache.tajo.ws.rs.netty.NettyRestHandlerContainer$NettyRestResponseWriter$1.operationComplete()
        org.glassfish.jersey.server.ContainerException: java.lang.IllegalStateException: ResponseWriter did not be commited.
        at org.apache.tajo.ws.rs.netty.NettyRestHandlerContainer$NettyRestResponseWriter$1.operationComplete(NettyRestHandlerContainer.java:254)
        at org.apache.tajo.ws.rs.netty.NettyRestHandlerContainer$NettyRestResponseWriter$1.operationComplete(NettyRestHandlerContainer.java:249)
        at io.netty.util.concurrent.DefaultPromise.notifyListener0(DefaultPromise.java:680)
        at io.netty.util.concurrent.DefaultPromise.notifyListeners(DefaultPromise.java:567)
        at io.netty.util.concurrent.DefaultPromise.tryFailure(DefaultPromise.java:424)
        at io.netty.handler.stream.ChunkedWriteHandler$PendingWrite.fail(ChunkedWriteHandler.java:345)
        at io.netty.handler.stream.ChunkedWriteHandler.discard(ChunkedWriteHandler.java:195)
        at io.netty.handler.stream.ChunkedWriteHandler.doFlush(ChunkedWriteHandler.java:203)
        at io.netty.handler.stream.ChunkedWriteHandler.flush(ChunkedWriteHandler.java:139)
        at io.netty.channel.AbstractChannelHandlerContext.invokeFlush(AbstractChannelHandlerContext.java:663)
        at io.netty.channel.AbstractChannelHandlerContext.write(AbstractChannelHandlerContext.java:693)
        at io.netty.channel.AbstractChannelHandlerContext.writeAndFlush(AbstractChannelHandlerContext.java:681)
        at org.apache.tajo.ws.rs.netty.NettyRestHandlerContainer$NettyRestResponseWriter.sendError(NettyRestHandlerContainer.java:259)
        at org.apache.tajo.ws.rs.netty.NettyRestHandlerContainer$NettyRestResponseWriter.failure(NettyRestHandlerContainer.java:236)
        at org.apache.tajo.ws.rs.netty.NettyRestHandlerContainer$NettyRestResponseWriter.releaseConnection(NettyRestHandlerContainer.java:297)
        at org.apache.tajo.ws.rs.netty.NettyRestHandlerContainer$NettyRestResponseWriter.access$000(NettyRestHandlerContainer.java:208)
        at org.apache.tajo.ws.rs.netty.NettyRestHandlerContainer.messageReceived(NettyRestHandlerContainer.java:158)
        at org.apache.tajo.ws.rs.netty.NettyRestHandlerContainer.channelRead(NettyRestHandlerContainer.java:168)
        at io.netty.channel.AbstractChannelHandlerContext.invokeCh6월 10, 2015 12:24:15 오후 org.glassfish.jersey.filter.LoggingFilter log
        정보: 1 * Client response received on thread main
        1 < 500
        1 < Content-Type: text/plain; charset=UTF-8

        annelRead(AbstractChannelHandlerContext.java:308)
        at io.netty.channel.AbstractChannelHandlerContext.fireChannelRead(AbstractChannelHandlerContext.java:294)
        at io.netty.channel.ChannelInboundHandlerAdapter.channelRead(ChannelInboundHandlerAdapter.java:86)
        at io.netty.channel.AbstractChannelHandlerContext.invokeChannelRead(AbstractChannelHandlerContext.java:308)
        at io.netty.channel.AbstractChannelHandlerContext.fireChannelRead(AbstractChannelHandlerContext.java:294)
        at io.netty.handler.codec.MessageToMessageDecoder.channelRead(MessageToMessageDecoder.java:103)
        at io.netty.channel.AbstractChannelHandlerContext.invokeChannelRead(AbstractChannelHandlerContext.java:308)
        at io.netty.channel.AbstractChannelHandlerContext.fireChannelRead(AbstractChannelHandlerContext.java:294)
        at io.netty.handler.codec.ByteToMessageDecoder.channelRead(ByteToMessageDecoder.java:182)
        at io.netty.channel.CombinedChannelDuplexHandler.channelRead(CombinedChannelDuplexHandler.java:147)
        at io.netty.channel.AbstractChannelHandlerContext.invokeChannelRead(AbstractChannelHandlerContext.java:308)
        at io.netty.channel.AbstractChannelHandlerContext.fireChannelRead(AbstractChannelHandlerContext.java:294)
        at io.netty.channel.DefaultChannelPipeline.fireChannelRead(DefaultChannelPipeline.java:846)
        at io.netty.channel.nio.AbstractNioByteChannel$NioByteUnsafe.read(AbstractNioByteChannel.java:130)
        at io.netty.channel.nio.NioEventLoop.processSelectedKey(NioEventLoop.java:511)
        at io.netty.channel.nio.NioEventLoop.processSelectedKeysOptimized(NioEventLoop.java:468)
        at io.netty.channel.nio.NioEventLoop.processSelectedKeys(NioEventLoop.java:382)
        at io.netty.channel.nio.NioEventLoop.run(NioEventLoop.java:354)
        at io.netty.util.concurrent.SingleThreadEventExecutor$2.run(SingleThreadEventExecutor.java:116)
        at java.lang.Thread.run(Thread.java:745)
        Caused by: java.lang.IllegalStateException: ResponseWriter did not be commited.
        ... 24 more

        javax.ws.rs.InternalServerErrorException: HTTP 500 Internal Server Error
        at org.glassfish.jersey.client.JerseyInvocation.convertToException(JerseyInvocation.java:929)
        at org.glassfish.jersey.client.JerseyInvocation.translate(JerseyInvocation.java:770)
        at org.glassfish.jersey.client.JerseyInvocation.access$500(JerseyInvocation.java:90)
        at org.glassfish.jersey.client.JerseyInvocation$2.call(JerseyInvocation.java:671)
        at org.glassfish.jersey.internal.Errors.process(Errors.java:315)
        at org.glassfish.jersey.internal.Errors.process(Errors.java:297)
        at org.glassfish.jersey.internal.Errors.process(Errors.java:228)
        at org.glassfish.jersey.process.internal.RequestScope.runInScope(RequestScope.java:423)
        at org.glassfish.jersey.client.JerseyInvocation.invoke(JerseyInvocation.java:667)
        at org.glassfish.jersey.client.JerseyInvocation$Builder.method(JerseyInvocation.java:423)
        at org.glassfish.jersey.client.JerseyInvocation$Builder.post(JerseyInvocation.java:326)
        at org.apache.tajo.ws.rs.resources.TestQueryResultResource.generateNewSessionAndGetId(TestQueryResultResource.java:95)
        at org.apache.tajo.ws.rs.resources.TestQueryResultResource.testGetQueryResultSetWithOffset(TestQueryResultResource.java:224)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:47)
        at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:12)
        at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:44)
        at org.junit.internal.runners.statements.InvokeMethod.evaluate(InvokeMethod.java:17)
        at org.junit.internal.runners.statements.RunBefores.evaluate(RunBefores.java:26)
        at org.junit.internal.runners.statements.RunAfters.evaluate(RunAfters.java:27)
        at org.junit.rules.TestWatcher$1.evaluate(TestWatcher.java:55)
        at org.junit.rules.TestWatcher$1.evaluate(TestWatcher.java:55)
        at org.junit.rules.RunRules.evaluate(RunRules.java:20)
        at org.junit.runners.ParentRunner.runLeaf(ParentRunner.java:271)
        at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:70)
        at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:50)
        at org.junit.runners.ParentRunner$3.run(ParentRunner.java:238)
        at org.junit.runners.ParentRunner$1.schedule(ParentRunner.java:63)
        at org.junit.runners.ParentRunner.runChildren(ParentRunner.java:236)
        at org.junit.runners.ParentRunner.access$000(ParentRunner.java:53)
        at org.junit.runners.ParentRunner$2.evaluate(ParentRunner.java:229)
        at org.junit.internal.runners.statements.RunBefores.evaluate(RunBefores.java:26)
        at org.junit.internal.runners.statements.RunAfters.evaluate(RunAfters.java:27)
        at org.junit.runners.ParentRunner.run(ParentRunner.java:309)
        at org.junit.runner.JUnitCore.run(JUnitCore.java:160)
        at com.intellij.junit4.JUnit4IdeaTestRunner.startRunnerWithArgs(JUnit4IdeaTestRunner.java:74)
        at com.intellij.rt.execution.junit.JUnitStarter.prepareStreamsAndStart(JUnitStarter.java:211)
        at com.intellij.rt.execution.junit.JUnitStarter.main(JUnitStarter.java:67)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        at com.intellij.rt.execution.application.AppMain.main(AppMain.java:134)

        ```

        githubbot ASF GitHub Bot added a comment -

        Github user blrunner commented on the pull request:

        https://github.com/apache/tajo/pull/598#issuecomment-109660613

        Hi folks

        This suggestion seems reasonable.
        What do you think about it?

        githubbot ASF GitHub Bot added a comment -

        GitHub user charsyam opened a pull request:

        https://github.com/apache/tajo/pull/598

        TAJO-1636 query rest api uri should change from /databases/

        {database_name}/queies to /queries

        currently, "databases" Rest Api uri has too many meaning.
        1. for query
        2. to manage databases info
        and databases/
        {database_name}

        /queries is not proper for queries

        so I suggest change from "/databases/

        {database_name}

        /queries" to
        "/queries/", it is more clear to understand.
        below apis will changed.
        POST /databases/

        {databaseName}/queries -> POST /queries
        GET /databases/{databaseName}

        /queries -> GET /queries
        GET /databases/

        {databaseName}/queries/{queryId} -> GET /queries/{queryId}
        GET /databases/{databaseName}

        /queries/

        {queryId}/result -> GET /queries/{queryId}

        /result
        GET /databases/

        {databaseName}

        /queries/

        {queryId}/result/{cacheId} -> GET /queries/{queryId}

        /result/

        {cacheId}

        You can merge this pull request into a Git repository by running:

        $ git pull https://github.com/charsyam/tajo feature/change-query-api-address

        Alternatively you can review and apply these changes as the patch at:

        https://github.com/apache/tajo/pull/598.patch

        To close this pull request, make a commit to your master/trunk branch
        with (at least) the following in the commit message:

        This closes #598


        commit f068436b62ea934e26efa85b8b78a78ca64215b0
        Author: clark.kang <clark.kang@kakao.com>
        Date: 2015-06-04T15:39:47Z

        change-query-api-address



          People

          • Assignee:
            charsyam DaeMyung Kang
            Reporter:
            charsyam DaeMyung Kang
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development