Uploaded image for project: 'Tajo'
  1. Tajo
  2. TAJO-1622

UniformRangePartition occasionally causes IllegalStateException

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.10.0
    • Fix Version/s: 0.11.0
    • Component/s: QueryMaster
    • Labels:
      None

      Description

      2015-05-26 20:15:47,544 INFO org.apache.tajo.querymaster.Repartitioner: eb_1432630858987_0005_000006, Try to divide [(12야,0), (히포크라테스,희망,199)) into 10 sub ranges (total units: 10)
      2015-05-26 20:15:47,551 ERROR org.apache.tajo.querymaster.Stage: Stage (eb_1432630858987_0005_000006) ERROR:
      java.lang.IllegalStateException
      at com.google.common.base.Preconditions.checkState(Preconditions.java:129)
      at org.apache.tajo.engine.planner.UniformRangePartition.isOverflow(UniformRangePartition.java:320)
      at org.apache.tajo.engine.planner.UniformRangePartition.increment(UniformRangePartition.java:450)
      at org.apache.tajo.engine.planner.UniformRangePartition.partition(UniformRangePartition.java:142)
      at org.apache.tajo.querymaster.Repartitioner.scheduleRangeShuffledFetches(Repartitioner.java:698)
      at org.apache.tajo.querymaster.Repartitioner.scheduleFragmentsForNonLeafTasks(Repartitioner.java:625)
      at org.apache.tajo.querymaster.Stage$InitAndRequestContainer.schedule(Stage.java:998)
      at org.apache.tajo.querymaster.Stage$InitAndRequestContainer.access$900(Stage.java:776)
      at org.apache.tajo.querymaster.Stage$InitAndRequestContainer$1.run(Stage.java:802)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
      at java.util.concurrent.FutureTask.run(FutureTask.java:262)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      at java.lang.Thread.run(Thread.java:745)
      

        Issue Links

          Activity

          jhkim Jinho Kim added a comment -

          This issue caused by race condition in StringUtils.isPureAscii. CharsetEncoder is not thread-safe.
          I was fix this in TAJO-1397


            People

            • Assignee:
              Unassigned
              Reporter:
              jhkim Jinho Kim
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development