Uploaded image for project: 'Tajo'
  1. Tajo
  2. TAJO-1425

SQLAnalyzer should print message to indicate exact error line with supplement

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.10.1
    • Component/s: SQL Parser
    • Labels:
      None

      Description

      Currently, SQLAnalyzer only prints exact error line and message for the most outer query. In other words, it does not handle the error inner subqueries.

      In many cases, query statements can be tens of lines to hundreds of lines. In this case, it is very hard to find what the problem is.

      The main objective of this issue is to print the exact error line. It would be greater if error message includes some supplementary messages to help user find the cause of errors.

        Issue Links

          Activity

          eminency Jongyoung Park added a comment -

          What purpose is DefaultTajoCliOutputFormatter.parseErrorMessage() used for?

          It seems the method is eliminating extra error information such error line number.

          eminency Jongyoung Park added a comment -

          This issue was already fixed at TAJO-1580 and TAJO-1576.


            People

            • Assignee:
              eminency Jongyoung Park
              Reporter:
              hyunsik Hyunsik Choi
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development