Uploaded image for project: 'Tajo'
  1. Tajo
  2. TAJO-1278

Unit tests occasionally hang due to the invalid query status

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.10.0
    • Component/s: Unit Test
    • Labels:
      None

      Description

      See the title.
      Sometimes, even though a query is successfully finished during unit tests, its state is not QUERY_SUCCEEDED at QueryClientImpl. As a result, the query runs forever.

        Issue Links

          Activity

          hyunsik Hyunsik Choi added a comment -

          I heard that many hints from Jihoon. I found that it is very related to my previous work TAJO-1228. So, I'll take this issue.

          jihoonson Jihoon Son added a comment -

          Thanks for taking.

          hyunsik Hyunsik Choi added a comment -

          The main cause is as follows. So far, we have used the query state maintained in QueryMaster. TAJO-1228 changes TajoClient to pass through only TajoMaster instead of QueryMaster. TajoMaster has not maintained running as well as finished query states. There are some synchronization issues and wrong implementation. Most of them are caused by messy code.

          So, instead of fixing only the problem itself, I'll create some refactoring and clean issues to recap them and cleanup the relationship between QueryInProgress and QueryJobManater.

          jihoonson Jihoon Son added a comment -

          This issue is fixed in TAJO-1282.


            People

            • Assignee:
              hyunsik Hyunsik Choi
              Reporter:
              jihoonson Jihoon Son
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development