Uploaded image for project: 'Tajo'
  1. Tajo
  2. TAJO-1111

TestKillQuery.testKillQueryFromInitState occasionally fails

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.9.0
    • Component/s: QueryMaster
    • Labels:
      None

      Description

      See the title. this test occasionally fails.

      [INFO] Results :
      [INFO] 
      [INFO] Failed tests: 
      [INFO]   TestKillQuery.testKillQueryFromInitState:104 expected:<QUERY_KILLED> but was:<QUERY_ERROR>
      [INFO] 
      [INFO] Tests run: 1234, Failures: 1, Errors: 0, Skipped: 0
      

        Activity

        hyunsik Hyunsik Choi added a comment -

        I tried to reproduce the bug for two days in order to get some detailed error log. It was hard to reproduce because it occurs rarely. Finally, I grabbed the detail error log!!!

        2014-10-10 09:05:12,569 INFO: org.apache.tajo.storage.AbstractStorageManager (listStatus(385)) - Total input paths to process : 1
        2014-10-10 09:05:12,570 INFO: org.apache.tajo.storage.AbstractStorageManager (getSplits(614)) - Total # of splits: 1
        2014-10-10 09:05:12,570 INFO: org.apache.tajo.master.querymaster.Query (handle(952)) - Processing q_1412957112432_0000 of type KILL
        2014-10-10 09:05:12,570 INFO: org.apache.tajo.master.querymaster.Query (handle(970)) - q_1412957112432_0000 Query Transitioned from QUERY_RUNNING to QUERY_KILL_WAIT
        2014-10-10 09:05:12,570 INFO: org.apache.tajo.master.DefaultTaskScheduler (stop(148)) - Task Scheduler stopped
        2014-10-10 09:05:12,570 INFO: org.apache.tajo.master.querymaster.SubQuery (run(673)) - 1 objects are scheduled
        2014-10-10 09:05:12,570 INFO: org.apache.tajo.master.DefaultTaskScheduler (handle(244)) - ta_1412957112432_0000_000001_000000_00 is canceled from DefaultTaskScheduler
        2014-10-10 09:05:12,570 INFO: org.apache.tajo.master.querymaster.QueryUnitAttempt (transition(326)) - ta_1412957112432_0000_000001_000000_00 Received TA_KILLED Status from LocalTask
        2014-10-10 09:05:12,571 ERROR: org.apache.tajo.master.querymaster.QueryUnit (handle(601)) - Can't handle this event at current state, eventType:T_KILL, oldState:KILLED, nextState:KILLED
        org.apache.hadoop.yarn.state.InvalidStateTransitonException: Invalid event: T_KILL at KILLED
          at org.apache.hadoop.yarn.state.StateMachineFactory.doTransition(StateMachineFactory.java:305)
          at org.apache.hadoop.yarn.state.StateMachineFactory.access$300(StateMachineFactory.java:46)
          at org.apache.hadoop.yarn.state.StateMachineFactory$InternalStateMachine.doTransition(StateMachineFactory.java:448)
          at org.apache.tajo.master.querymaster.QueryUnit.handle(QueryUnit.java:599)
          at org.apache.tajo.master.querymaster.QueryMasterTask$TaskEventDispatcher.handle(QueryMasterTask.java:286)
          at org.apache.tajo.master.querymaster.QueryMasterTask$TaskEventDispatcher.handle(QueryMasterTask.java:277)
          at org.apache.tajo.master.TajoAsyncDispatcher.dispatch(TajoAsyncDispatcher.java:137)
          at org.apache.tajo.master.TajoAsyncDispatcher$1.run(TajoAsyncDispatcher.java:79)
          at java.lang.Thread.run(Thread.java:744)
        2014-10-10 09:05:12,571 INFO: org.apache.tajo.master.querymaster.SubQuery (transition(1114)) - [eb_1412957112432_0000_000001] Task Completion Event (Total: 1, Success: 0, Killed: 1, Failed: 0)
        2014-10-10 09:05:12,571 INFO: org.apache.tajo.master.querymaster.Query (handle(952)) - Processing q_1412957112432_0000 of type INTERNAL_ERROR
        2014-10-10 09:05:12,572 INFO: org.apache.tajo.master.querymaster.Query (handle(970)) - q_1412957112432_0000 Query Transitioned from QUERY_KILL_WAIT to QUERY_ERROR
        2014-10-10 09:05:12,572 INFO: org.apache.tajo.master.querymaster.SubQuery (transition(1216)) - subQuery completed - eb_1412957112432_0000_000001 (total=1, success=0, killed=1)
        2014-10-10 09:05:12,572 INFO: org.apache.tajo.master.querymaster.QueryMaster (cleanupExecutionBlock(186)) - cleanup executionBlocks:
        2014-10-10 09:05:12,572 INFO: org.apache.tajo.master.querymaster.QueryMasterTask (handle(323)) - Query completion notified from q_1412957112432_0000
        2014-10-10 09:05:12,572 INFO: org.apache.tajo.master.querymaster.QueryMasterTask (handle(334)) - Query final state: QUERY_ERROR
        2014-10-10 09:05:12,572 INFO: org.apache.tajo.master.querymaster.Query (handle(952)) - Processing q_1412957112432_0000 of type SUBQUERY_COMPLETED
        2014-10-10 09:05:12,572 ERROR: org.apache.tajo.master.querymaster.Query (handle(960)) - Can't handle this event at current state, type:EventType: SUBQUERY_COMPLETED, oldState:QUERY_ERROR, nextState:QUERY_ERROR
        org.apache.hadoop.yarn.state.InvalidStateTransitonException: Invalid event: SUBQUERY_COMPLETED at QUERY_ERROR
          at org.apache.hadoop.yarn.state.StateMachineFactory.doTransition(StateMachineFactory.java:305)
          at org.apache.hadoop.yarn.state.StateMachineFactory.access$300(StateMachineFactory.java:46)
          at org.apache.hadoop.yarn.state.StateMachineFactory$InternalStateMachine.doTransition(StateMachineFactory.java:448)
          at org.apache.tajo.master.querymaster.Query.handle(Query.java:957)
          at org.apache.tajo.master.querymaster.Query.handle(Query.java:63)
          at org.apache.tajo.master.TajoAsyncDispatcher.dispatch(TajoAsyncDispatcher.java:137)
          at org.apache.tajo.master.TajoAsyncDispatcher$1.run(TajoAsyncDispatcher.java:79)
          at java.lang.Thread.run(Thread.java:744)
        2014-10-10 09:05:12,573 INFO: org.apache.tajo.master.querymaster.Query (handle(952)) - Processing q_1412957112432_0000 of type INTERNAL_ERROR
        2014-10-10 09:05:12,573 INFO: org.apache.tajo.master.querymaster.QueryMasterTask (handle(323)) - Query completion notified from q_1412957112432_0000
        2014-10-10 09:05:12,573 INFO: org.apache.tajo.master.querymaster.QueryMasterTask (handle(334)) - Query final state: QUERY_ERROR
        Tests run: 1, Failures: 1, Errors: 0, Skipped: 0, Time elapsed: 2.408 sec <<< FAILURE! - in org.apache.tajo.master.querymaster.TestKillQuery
        testKillQueryFromInitState(org.apache.tajo.master.querymaster.TestKillQuery)  Time elapsed: 2.408 sec  <<< FAILURE!
        java.lang.AssertionError: expected:<QUERY_KILLED> but was:<QUERY_ERROR>
          at org.junit.Assert.fail(Assert.java:88)
          at org.junit.Assert.failNotEquals(Assert.java:743)
          at org.junit.Assert.assertEquals(Assert.java:118)
          at org.junit.Assert.assertEquals(Assert.java:144)
          at org.apache.tajo.master.querymaster.TestKillQuery.testKillQueryFromInitState(TestKillQuery.java:104)
        
        Running org.apache.tajo.master.querymaster.TestQueryProgress
        2014-10-10 09:05:14,717 INFO: org.apache.tajo.master.session.SessionManager (createSession(73)) - Session 8297515c-6bca-4617-a4d5-bf92f332075a is created.
        2014-10-10 09:05:14,717 INFO: org.apache.tajo.master.GlobalEngine (executeQuery(156)) - Query: select l_orderkey from lineitem group by l_orderkey
        2014-10-10 09:05:14,731 INFO: org.apache.tajo.master.GlobalEngine (createLogicalPlan(507)) - Non Optimized Query:
        
        hyunsik Hyunsik Choi added a comment - - edited

        As my investigation on the state machines, I found the two missed cases:

        KILLED state cannot be transited to T_KILL, T_ATTEMPT_KILLED, or T_ATTEMPT_SUCCEEDED. The states may receive multiple times form workers because workers has some state reporter will periodically send the current task state. They are possible cases in concurrent and distributed cases.

        I think that they should also handle T_ATTEMPT_FAILED in the same way. In sum, SUCCEEDED, FAILED, KILLED should handle T_KILL, T_ATTEMPT_KILLED, T_ATTEMPT_SUCCEEDED, or T_ATTEMPT_FAILED as ignorable state transitions.

        In addition, It's possible if QUERY_ERROR state in Query can take SUBQUERY_COMPLETED because KILLED and FAILED also send SUBQUERY_COMPLETED event to Query. In this case, we have to ignore because Query state is already in QUERY_ERROR.

        I'll submit the patch soon.

        hyunsik Hyunsik Choi added a comment - - edited

        See the below line. I cannot ensure why KillTaskTransition is required in the terminal state KILLED.

        'QueryUnit.java'
        .addTransition(TaskState.KILLED, TaskState.KILLED, TaskEventType.T_ATTEMPT_KILLED, new KillTaskTransition())
        

        If we ensure that KILLED state means QueryUnitAttempt is in KILLED, KillTaskTransition has no effect because TA_KILL event is ignored in the TA_KILLED state.

        'QueryUnitAttempt.java'
        .addTransition(TaskAttemptState.TA_KILLED, TaskAttemptState.TA_KILLED,
                  EnumSet.of(
                      TaskAttemptEventType.TA_LOCAL_KILLED,
                      TaskAttemptEventType.TA_KILL,
                      TaskAttemptEventType.TA_ASSIGNED,
                      TaskAttemptEventType.TA_DONE),
                  new TaskKilledCompleteTransition())
        

        But, I won't modify the state transitions in this release. As far as I know, the current master is already being used in many productions. This change may cause potential side effect. After 0.9.0 release, we can investigate its necessity.

        githubbot ASF GitHub Bot added a comment -

        GitHub user hyunsik opened a pull request:

        https://github.com/apache/tajo/pull/198

        TAJO-1111: TestKillQuery.testKillQueryFromInitState occasionally fails.

        It just adds ignorable state transitions. So, I omit the unit tests.

        You can merge this pull request into a Git repository by running:

        $ git pull https://github.com/hyunsik/tajo TAJO-1111

        Alternatively you can review and apply these changes as the patch at:

        https://github.com/apache/tajo/pull/198.patch

        To close this pull request, make a commit to your master/trunk branch
        with (at least) the following in the commit message:

        This closes #198


        commit 2cd839a56978d975ca7df04fde3b5206696e5e79
        Author: Hyunsik Choi <hyunsik@apache.org>
        Date: 2014-10-10T18:22:19Z

        TAJO-1111: TestKillQuery.testKillQueryFromInitState occasionally fails.


        githubbot ASF GitHub Bot added a comment -

        Github user jinossy commented on the pull request:

        https://github.com/apache/tajo/pull/198#issuecomment-58765010

        +1 LGTM

        githubbot ASF GitHub Bot added a comment -

        Github user hyunsik commented on the pull request:

        https://github.com/apache/tajo/pull/198#issuecomment-58765406

        Thank you for the quick review.

        githubbot ASF GitHub Bot added a comment -

        Github user asfgit closed the pull request at:

        https://github.com/apache/tajo/pull/198

        hyunsik Hyunsik Choi added a comment -

        committed it to master branch.

        hudson Hudson added a comment -

        SUCCESS: Integrated in Tajo-master-build #409 (See https://builds.apache.org/job/Tajo-master-build/409/)
        TAJO-1111: TestKillQuery.testKillQueryFromInitState occasionally fails. (hyunsik: rev 22c43c0aded9b4689f863b38550c52d5ee5135c5)

        • CHANGES
        • tajo-core/src/main/java/org/apache/tajo/master/querymaster/QueryUnit.java
        • tajo-core/src/main/java/org/apache/tajo/master/querymaster/Query.java
        hudson Hudson added a comment -

        ABORTED: Integrated in Tajo-master-CODEGEN-build #51 (See https://builds.apache.org/job/Tajo-master-CODEGEN-build/51/)
        TAJO-1111: TestKillQuery.testKillQueryFromInitState occasionally fails. (hyunsik: rev 22c43c0aded9b4689f863b38550c52d5ee5135c5)

        • CHANGES
        • tajo-core/src/main/java/org/apache/tajo/master/querymaster/Query.java
        • tajo-core/src/main/java/org/apache/tajo/master/querymaster/QueryUnit.java
        hudson Hudson added a comment -

        SUCCESS: Integrated in Tajo-block_iteration-branch-build #15 (See https://builds.apache.org/job/Tajo-block_iteration-branch-build/15/)
        TAJO-1111: TestKillQuery.testKillQueryFromInitState occasionally fails. (hyunsik: rev 22c43c0aded9b4689f863b38550c52d5ee5135c5)

        • tajo-core/src/main/java/org/apache/tajo/master/querymaster/QueryUnit.java
        • CHANGES
        • tajo-core/src/main/java/org/apache/tajo/master/querymaster/Query.java

          People

          • Assignee:
            hyunsik Hyunsik Choi
            Reporter:
            hyunsik Hyunsik Choi
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development