Uploaded image for project: 'Syncope'
  1. Syncope
  2. SYNCOPE-1453

MappingItem with "mustChangePassword" field cannot be provisioned and updated during import

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.12, 2.1.3
    • Fix Version/s: 2.0.13, 2.1.4, 3.0.0
    • Component/s: core
    • Labels:
      None

      Description

      1. Adding the mapping item into provisioning rules of the resource doesn't allow to provision the updates made in org.apache.syncope.common.lib.to.UserTO#mustChangePassword field.

      2. Imported value from remote identity storage cannot be set to the already existing user stored in the Syncope

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                ilgrosso Francesco Chicchiriccò
                Reporter:
                Dmitriy.Brashevets Dmitriy
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 0.5h
                  0.5h