Uploaded image for project: 'Syncope'
  1. Syncope
  2. SYNCOPE-111

Failure during role attribute propagation

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.0.0-incubating
    • Fix Version/s: 1.0.0-incubating
    • Component/s: core
    • Labels:
      None

      Description

      Let's considering a role with a certain attribute memberOf to be propagated towards the resource X assigned to the role.

      Creating a membership with this role the propagation works fine: memberOf will be propagated correctly ...

      But, removing the membership, if the user mustn't be removed from the resource (see SYNCOPE-108), the resource attribute mapped with memberOf won't be updated.

      Case:
      1. create role A and role B with memberOf m1 and m2 respectively.
      2. assign the same resource X to A and B and define a schema mapping for memberOf (suppose a multivalue resource attribute 'm')
      3. create a user specifying two memberships: one form A and one for B
      4. verify that the resource attribute 'm' has been valued with m1 and m2
      5. modify the user profile just by removing a membership
      6. ... resource profile won't be updated correctly: te resource attribute 'm' won't be updated (it should be valued with one single value, m1 or m2)

        Attachments

          Activity

            People

            • Assignee:
              fmartelli fabio martelli
              Reporter:
              fmartelli fabio martelli
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: