Uploaded image for project: 'Subversion'
  1. Subversion
  2. SVN-3167

regression in 1.5 accessing server root

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.5.x
    • Fix Version/s: 1.5.0
    • Component/s: unknown
    • Labels:
      None

      Description

      Reported on the mailing list here:
      http://subversion.tigris.org/servlets/BrowseList?list=dev&by=thread&from=645838
      
      Summary:
      
      set up apache (only tried with https, not http but it shouldn't make a 
      difference), use this location block:
      
      <Location />
      	DAV svn
      	SVNPath D:/Development/repos/test
      	AuthType Basic
      	AuthName "Subversion repositories"
      	AuthUserFile passwd
      	Require valid-user
      	#AuthzSVNAccessFile conf/svnaccessfile
      </Location>
      
      (my server is running on Vista, svn 1.4.5)
      
      Then, with an 1.4.x client, do
      $ svn co https://server/ workingcopy
      
      it will succeed.
      
      But with an 1.5 client, this doesn't work:
      $ svn co https://server/ workingcopy
      svn: OPTIONS of 'https://server': Could not parse response status line 
      (https://server)
      

      http://subversion.tigris.org/servlets/BrowseList?list=dev&by=thread&from=645838

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              steveking Stefan K√ľng
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: