Uploaded image for project: 'Subversion'
  1. Subversion
  2. SVN-3119

"File '...' already exists" when it obviously doesn't, during commit

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 1.5.x
    • Fix Version/s: 1.6.5
    • Component/s: libsvn_ra_neon
    • Labels:
      None

      Description

      I ran into the same issue as described exactly here:
      
      http://www.opensubscriber.com/message/users@subversion.tigris.org/8177435.html
      
      I merged a set of changes down to my trunk working copy, and when I tried to
      commit it would fail saying my adds already existed in the repository when the
      definitely did not.
      
      I worked around this by reverting the adds, checking in most of the merge,
      readding the adds and checking them in with a second revision. Ugly, but I was
      able to work around it. Though it wasted a good bit of my time figuring it out.
      

      http://www.opensubscriber.com/message/users@subversion.tigris.org/8177435.html

      Original issue reported by evanleonard

        Attachments

        1. 1_issue-3119-1.sh
          2 kB
          Julian Foad

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              subversion-importer Subversion Importer
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: