Uploaded image for project: 'Subversion'
  1. Subversion
  2. SVN-2800

Ensure that libsvn_ra_dav->libsvn_ra_neon change doesn't hurt third-party programs linked to us

    XMLWordPrintableJSON

    Details

    • Type: Task
    • Status: Closed
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: trunk
    • Fix Version/s: 1.5.0
    • Component/s: libsvn_ra_neon
    • Labels:
      None

      Description

      On trunk, we renamed libsvn_ra_dav to libsvn_ra_neon.  This has no compatibility
      issues for Subversion's core programs, which already do version number checks
      against the libraries.  And third-party programs shouldn't be linking to
      libsvn_ra_dav, which has no public API, but just to libsvn_ra.  However, they
      may be some problems where some libtools build third-party programs with
      -lsvn_ra_dav anyway.  I do not fully understand the issues involved; Peter
      Samuelson described some of them here:
      
      http://svn.haxx.se/dev/archive-2007-06/0534.shtml
      
      We should make sure the situation is acceptable before releasing 1.5.
      

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              glasser David Samuel Glasser
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: