Uploaded image for project: 'Subversion'
  1. Subversion
  2. SVN-2756

Subversion 1.4.3 fails to build without Berkeley DB

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Invalid
    • Affects Version/s: 1.4.x
    • Fix Version/s: nonblocking
    • Component/s: compile
    • Labels:
      None
    • Environment:

      Linux

      Description

      I downloaded Subversion 1.4.3 (but the same problem exists in 1.4.0) and tried
      to build it.
      
      When running configure, it ended by saying
      
      "configure: WARNING: we have configured without BDB filesystem support
      
      You don't seem to have Berkeley DB version 4.0.14 or newer
      installed and linked to APR-UTIL.  We have created Makefiles which
      will build without the Berkeley DB back-end; your repositories will
      use FSFS as the default back-end.  You can find the latest version of
      Berkeley DB here:
        http://www.sleepycat.com/download/index.shtml"
      
      But since I wasn't interested in Berkeley DB support I didn't worry, since the
      message indicated that I should be able to build without it.
      
      Note that there is no configure output indicating that it searched for any db
      support.
      
      However, running make failed:
      
      cd subversion/libsvn_subr && /bin/bash /home/david/tmp/subversion-1.4.3/libtool
      --tag=CC --silent --mode=link gcc  -g -O2  -pipe -Wall -g -O2 -pthread 
      -D_LARGEFILE64_SOURCE -DNE_LFS  -L/usr/lib  -rpath /usr/local/lib -o
      libsvn_subr-1.la  auth.lo cmdline.lo compat.lo config.lo config_auth.lo
      config_file.lo config_win.lo constructors.lo ctype.lo date.lo dso.lo error.lo
      hash.lo io.lo kitchensink.lo lock.lo md5.lo nls.lo opt.lo path.lo pool.lo
      prompt.lo quoprint.lo simple_providers.lo sorts.lo ssl_client_cert_providers.lo
      ssl_client_cert_pw_providers.lo ssl_server_trust_providers.lo stream.lo subst.lo
      svn_base64.lo svn_string.lo target.lo time.lo user.lo username_providers.lo
      utf.lo utf_validate.lo validate.lo version.lo xml.lo /usr/lib/libaprutil-1.la
      -lldap -llber -ldb-4.2 -lpq -lsqlite3 -lexpat /usr/lib/libapr-1.la -lrt -lcrypt
       -lpthread -ldl -lz
      grep: /usr/lib/libdb-4.2.la: No such file or directory
      /bin/sed: can't read /usr/lib/libdb-4.2.la: No such file or directory
      libtool: link: `/usr/lib/libdb-4.2.la' is not a valid libtool archive
      
      I initially tried to install the latest libdb4.4-dev from ubuntu, and reran
      configure and make, but that didn't help one bit.
      
      Then I read the error message more closely and saw that it was trying to use
      /usr/lib/libdb-4.2.la.  So I installed libdb4.2-dev instead, and the build
      succeeded.
      
      I can see several problems here:
      
      1) There isn't any "checking for berkeley db" output
      
      2) The configure message claims to have created makefiles to build without it. 
      But that's not true.
      
      3) The message states that I need 4.0.14 "or later", while only 4.2 seems to do.
      
      4) Shouldn't I be able to use 4.4?
      

      Original issue reported by dkagedal

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              subversion-importer Subversion Importer
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: