Uploaded image for project: 'Subversion'
  1. Subversion
  2. SVN-1510

cvs2svn: No support for vendor branches

VotersWatch issueWatchersLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: all
    • Fix Version/s: cvs2svn-1.0
    • Component/s: tools
    • Labels:
      None

      Description

      At this time (r7006), cvs2svn does not support vendor branches.
      This is because it ignores the "branch" statement in RCS files.
      
      Scenario:
      Using CVS to develop myprog.
      Import foolib-0.9. Develop myprog using foolib's 0.9 API.
      Import foolib-1.0. Modify myprog to use foolib's 1.0 API.
      Import foolib-2.0. Modify myprog to use foolib's 2.0 API.
      No local modifications have been made to foolib at any time.
      Convert to SVN using cvs2svn.
      Check out trunk. The checked out myprog is using the foolib 2.0 API,
      but foolib-0.9 has been checked out from trunk into the working copy.
      myprog won't compile.
      
      It may be appropriate for cvs2svn to refuse to process any RCS files
      containing a vendor branch, until proper support can be coded. (A
      special exception could be made for cases where r.1.1 == r1.1.1.1)
      

        Attachments

        1. 1_vbranch.sh
          4 kB
          Subversion Importer
        2. 2_testing.sh
          2 kB
          Karl Fogel
        3. 3_1510-1474.patch-in-progress.txt
          7 kB
          Karl Fogel

        Issue Links

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              maxb Max Oliver Bowsher

              Dates

              • Created:
                Updated:
                Resolved:

                Issue deployment