Uploaded image for project: 'Maven Surefire'
  1. Maven Surefire
  2. SUREFIRE-570

Empty surefire reports when a multi-module project is ran with multiple report directories in surefire-report configuration

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.4.3
    • Fix Version/s: 2.7.2
    • Labels:
      None
    • Environment:
      Tested on Windows XP & Linux (Ubuntu 09.04) with Maven 2.0.10

      Description

      With a multi-module project, if the reporting configuration set multiple report directories (in the parent POM), then the report / report-only goals generate empty report.

      The main / aggregated report says this is 0 Tests.
      Module reports are empty html files.

      The attached project is a sample project to reproduce this ...

      The parent POM reporting conf explicitely set 2 reporting directories.

      From the "parent" POM :

      • mvn surefire-report:report ==> normal report per modules, nothing to say
      • mvn clean
      • mvn surefire-report:report -Daggregate=true ==> parent report with 0 tests, empty html report for modules
      • mvn surefire-report:report; mvn surefire-report:report-only -Daggregate=true ==> idem, parent report with 0 tests, empty html report for modules

        Attachments

        1. SUREFIRE-570.diff
          3 kB
          Thomas Sauzedde
        2. surefire-report-test.tar.gz
          6 kB
          Thomas Sauzedde

          Issue Links

            Activity

              People

              • Assignee:
                krosenvold Kristian Rosenvold
                Reporter:
                tsauzedde Thomas Sauzedde
              • Votes:
                4 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: