Uploaded image for project: 'Maven Surefire'
  1. Maven Surefire
  2. SUREFIRE-1223

Cannot run invoker ITs on Windows with Maven 3.3.1+

    Details

    • Type: Task
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.19.1
    • Fix Version/s: 2.20
    • Component/s: Maven Failsafe Plugin
    • Labels:
      None

      Description

      The error output is:

      [INFO]
      [INFO] --- maven-invoker-plugin:1.9:run (integration-test) @ maven-failsafe-plugin ---
      [INFO] Building: jetty-war-test-failing\pom.xml
      [INFO] ..FAILED (0.0 s)
      [INFO]   Maven invocation failed. Error configuring command-line. Reason: Maven executable not found at: D:\Entwicklung\Programme\apache-maven-3.3.9\bin\mvn.bat
      [INFO] Building: jetty-war-test-passing\pom.xml
      [INFO] ..FAILED (0.0 s)
      [INFO]   Maven invocation failed. Error configuring command-line. Reason: Maven executable not found at: D:\Entwicklung\Programme\apache-maven-3.3.9\bin\mvn.bat
      [INFO] Building: multiple-summaries\pom.xml
      [INFO] ..FAILED (0.0 s)
      [INFO]   Maven invocation failed. Error configuring command-line. Reason: Maven executable not found at: D:\Entwicklung\Programme\apache-maven-3.3.9\bin\mvn.bat
      [INFO] Building: multiple-summaries-failing\pom.xml
      [INFO] ..FAILED (0.0 s)
      [INFO]   Maven invocation failed. Error configuring command-line. Reason: Maven executable not found at: D:\Entwicklung\Programme\apache-maven-3.3.9\bin\mvn.bat
      [INFO] Building: working-directory\pom.xml
      [INFO] ..FAILED (0.0 s)
      [INFO]   Maven invocation failed. Error configuring command-line. Reason: Maven executable not found at: D:\Entwicklung\Programme\apache-maven-3.3.9\bin\mvn.bat
      [INFO] -------------------------------------------------
      

      Maven Invoker Plugin version needs to be updated.

        Issue Links

          Activity

          Hide
          michael-o Michael Osipov added a comment -

          All is well, passed locally with 3.2.5 and Jenkins with 3.0.5.

          Show
          michael-o Michael Osipov added a comment - All is well, passed locally with 3.2.5 and Jenkins with 3.0.5.
          Hide
          hudson Hudson added a comment -

          SUCCESS: Integrated in maven-surefire #1578 (See https://builds.apache.org/job/maven-surefire/1578/)
          SUREFIRE-1223 Cannot run invoker ITs on Windows with Maven 3.3.1+ (michaelo: rev dcd78c05bdd56c917d75dfee60b836e874c22625)

          • surefire-setup-integration-tests/pom.xml
          • maven-failsafe-plugin/pom.xml
          • pom.xml
          Show
          hudson Hudson added a comment - SUCCESS: Integrated in maven-surefire #1578 (See https://builds.apache.org/job/maven-surefire/1578/ ) SUREFIRE-1223 Cannot run invoker ITs on Windows with Maven 3.3.1+ (michaelo: rev dcd78c05bdd56c917d75dfee60b836e874c22625) surefire-setup-integration-tests/pom.xml maven-failsafe-plugin/pom.xml pom.xml
          Hide
          michael-o Michael Osipov added a comment - - edited

          We probably misunderstood each other, this is what I did in the commit. I will rerun the full tests with Maven 3.0.5 and 3.2.5 and will let you know. The commit works for 3.3.9.

          Show
          michael-o Michael Osipov added a comment - - edited We probably misunderstood each other, this is what I did in the commit. I will rerun the full tests with Maven 3.0.5 and 3.2.5 and will let you know. The commit works for 3.3.9.
          Hide
          tibor17 Tibor Digana added a comment -

          Try to update the invoker plugin in Surefire project, but I had the same
          problem with MVN 3.3..x and I am not sure if the version solved this.

          On Sat, Jan 30, 2016 at 1:44 PM, Michael Osipov (JIRA) <jira@apache.org>

          Show
          tibor17 Tibor Digana added a comment - Try to update the invoker plugin in Surefire project, but I had the same problem with MVN 3.3..x and I am not sure if the version solved this. On Sat, Jan 30, 2016 at 1:44 PM, Michael Osipov (JIRA) <jira@apache.org>
          Hide
          michael-o Michael Osipov added a comment - - edited

          This is annoything, I thought MINVOKER-185 handles it properly. How can we make it run on both?

          Show
          michael-o Michael Osipov added a comment - - edited This is annoything, I thought MINVOKER-185 handles it properly. How can we make it run on both?
          Hide
          tibor17 Tibor Digana added a comment -

          Michael Osipov
          Michael Osipov
          Michael, it fails because MVN 3.3.x contains mvn.cmd but MVN 3.2.x contains mvn.bat.

          Show
          tibor17 Tibor Digana added a comment - Michael Osipov Michael Osipov Michael, it fails because MVN 3.3.x contains mvn.cmd but MVN 3.2.x contains mvn.bat.
          Hide
          michael-o Michael Osipov added a comment -
          Show
          michael-o Michael Osipov added a comment - Fixed with dcd78c05bdd56c917d75dfee60b836e874c22625 .

            People

            • Assignee:
              michael-o Michael Osipov
              Reporter:
              michael-o Michael Osipov
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development