Uploaded image for project: 'Stratos'
  1. Stratos
  2. STRATOS-940

Python Agent does not publish health stats upon a restart in Stratos

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 4.1.0 M3
    • Fix Version/s: 4.1.0 RC3
    • Component/s: Cartridge Agent
    • Labels:
      None

      Description

      This should be easily reproducible.

      • Let agent publish health stats
      • restart Stratos
      • Agent won't publish stats --> faulty member detected
      • hence instances terminated

        Activity

        githubbot ASF GitHub Bot added a comment -

        GitHub user chamilad opened a pull request:

        https://github.com/apache/stratos/pull/115

        STRATOS-940 - Python Agent does not publish health stats upon a restart in Stratos

        Raise ThriftReceiverOfflineException when exception occurs while publishing event. Healthstats catch ThriftReceiverOfflineException and tries to reconnect forever

        You can merge this pull request into a Git repository by running:

        $ git pull https://github.com/chamilad/stratos master

        Alternatively you can review and apply these changes as the patch at:

        https://github.com/apache/stratos/pull/115.patch

        To close this pull request, make a commit to your master/trunk branch
        with (at least) the following in the commit message:

        This closes #115


        commit a13146852417e70fa18101660cb78791a2ca20ac
        Author: Chamila de Alwis <cs@chamiladealwis.com>
        Date: 2014-11-12T09:35:46Z

        STRATOS-940 - Python Agent does not publish health stats upon a restart in Stratos - Catch the read and write exceptions from the socket and continue without crashing

        commit 2efcb97f96b3fe9195fece4d4a5eb5e41ef0ae0c
        Author: Chamila de Alwis <cs@chamiladealwis.com>
        Date: 2014-11-12T10:07:48Z

        STRATOS-940 - Reconnect when connection fails until forever.

        commit 20022bc99c54f24b0b6427a794306eb4ed26ef68
        Author: Chamila de Alwis <cs@chamiladealwis.com>
        Date: 2014-11-12T10:31:09Z

        STRATOS-940 - Raise ThriftReceiverOfflineException when exception occurs while publishing event. Healthstats catch ThriftReceiverOfflineException and tries to reconnect forever.

        commit 94e03bd8f7e12888a371b7004d0b48ef43a42352
        Author: Chamila de Alwis <cs@chamiladealwis.com>
        Date: 2014-11-12T10:31:33Z

        Merge branch 'master' of https://github.com/apache/stratos


        chamilad Chamila de Alwis added a comment -

        Fixed. Included in the PR #115. Please merge.

        The root cause was the Thrift event publisher crashing when the CEP goes down with Stratos. The solution implemented is to throw a ThriftReceiverOfflineException when an error is thrown from the TSocker class and health stat publisher trying to re-establish the connection upon ThriftReceiverOfflineException.

        https://github.com/apache/stratos/pull/115

        githubbot ASF GitHub Bot added a comment -

        Github user asfgit closed the pull request at:

        https://github.com/apache/stratos/pull/115

        chamilad Chamila de Alwis added a comment -

        Fixed as per above comments


          People

          • Assignee:
            chamilad Chamila de Alwis
            Reporter:
            nirmal Nirmal Fernando
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development