Uploaded image for project: 'Stratos'
  1. Stratos
  2. STRATOS-611

Support OpenJDK for running Stratos

Details

    Description

      The most unreliable part of automating a Stratos runtime/development environment is the step that has to retrieve Sun JDK.

      I have been using the instructions here:
      https://ivan-site.com/2012/05/download-oracle-java-jre-jdk-using-a-script

      I believe we should support OpenJDK in addition to Sun JDK.

      Unless there are really strong objections, or reasons for not supporting OpenJDK, I will adapt the puppet scripts to support both Sun and Open JDKs.

      Attachments

        Activity

          People

            Unassigned Unassigned
            snowch chris snow
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment