Uploaded image for project: 'Apache Storm'
  1. Apache Storm
  2. STORM-3106

Clarify hive version requirement in storm-hive documentation

    Details

    • Type: Improvement
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      storm-hive uses 3 dependencies from org.apache.hive.hcatalog. All the dependencies are compiled with hive.version hardcoded here.

      If hive.version doesn't match the hive cluster's version there could be issues because of version mismatch such as this. I see two ways of fixing this -

      • Allow users to specify hive.version when using storm-hive dependency.
      • Update storm-hive documentation to state that user's need to copy the 3 dependencies needed by storm-hive and specify the correct hive version for them.

      Open to any other ideas.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              aandis Abhishek
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: