Uploaded image for project: 'Apache Storm'
  1. Apache Storm
  2. STORM-2803

SlotTest failing on travis frequently

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.0
    • Fix Version/s: 2.0.0
    • Component/s: None

      Description

      I have seen SlotTest fail way too frequently on travis, but it never fails off of travis.

      My guess is that there is some kind of a race condition happening and on slower hardware (aka VMs or Containers on overloaded build machines) that the tests tend to fail.

      I'll try to find some time to look at this, but if someone else wants to steal it from me feel free to. I don't know exactly when I will find time to do it.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                srdo Stig Rohde Døssing
                Reporter:
                revans2 Robert Joseph Evans
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 1h 10m
                  1h 10m