Details

    • Type: Sub-task Sub-task
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.2.0
    • Fix Version/s: 4.2.1
    • Component/s: 26. Numerics
    • Labels:
      None
    • Environment:

      $ uname -sr && aCC -V
      HP-UX B.11.31
      aCC: HP C/aC++ B3910B A.06.16 [Nov 26 2007]

      Description

      Compiling the indirect_array.cpp example with HP aCC 6.16 with optimization produces the following warning:

      aCC -c    -mt -I$(TOPDIR)/include -I$(BUILDDIR)/include -I$(TOPDIR)/examples/include  \
          -AA  +O2  +DD64 +w +W392 +W655 +W684 +W818 +W819 +W849 +W2193 +W2236  +W2261 +W2340  +W2401 \
          +W2487 +W4227 +W4229 +W4231 +W4235 +W4237 +W4249 +W4255 +W4272 +W4284 +W4285 +W4286   \
          $(TOPDIR)/examples/manual/indirect_array.cpp
      "$(TOPDIR)/include/valarray", line 2305, procedure main: warning #20200-D: Potential null pointer dereference through __tmp is detected (null definition:$(TOPDIR)/include/rw/_array.h, line 137)
      

        Issue Links

          Activity

          Farid Zaripov added a comment -
          Martin Sebor added a comment -

          Warning silenced in r640582.
          Will close after integrating to 4.2.x in the next bulk merge.

          Martin Sebor added a comment -

          The warning is caused by the HP aCC/cadvise bug described in STDCXX-793.

          Martin Sebor added a comment -

          Included the context of the warning, including the full command line.
          Set Component/s.
          Assigned to self.

          Martin Sebor added a comment -

          The warning is for <valarray>. Corrected Summary.


            People

            • Assignee:
              Martin Sebor
              Reporter:
              Scott (Yu) Zhong
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 2h Original Estimate - 2h
                2h
                Remaining:
                Remaining Estimate - 0h
                0h
                Logged:
                Time Spent - 4h
                4h

                  Development