Uploaded image for project: 'C++ Standard Library'
  1. C++ Standard Library
  2. STDCXX-43

names of atomic functions inconsitent

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Open
    • Priority: Trivial
    • Resolution: Unresolved
    • Affects Version/s: 4.1.2
    • Fix Version/s: 5.0.0
    • Component/s: Build and Installation
    • Labels:
      None
    • Environment:

      all

    • Severity:
      Cosmetic

      Description

      The names of the implementation-specific atomic functions are inconsistent: some contain the width of the type they operate on (such as __rw_atomic_add32()), others don't (e.g., __rw_atomic_add32()), and others still follow a different naming convention altogether (e.g., __rw_atomic_incr32()). This makes understanding and writing the generic overloads that use them (e.g., __rw_atomic_preincrement(), etc.) difficult and leads to lots of duplicate code in rw/_mutex.h. This is a placeholder issue to rename these functions using a consistent naming convention and to simplify rw/_mutex.h.

        Attachments

          Activity

            People

            • Assignee:
              sebor Martin Sebor
              Reporter:
              sebor Martin Sebor
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:

                Time Tracking

                Estimated:
                Original Estimate - 4h
                4h
                Remaining:
                Remaining Estimate - 4h
                4h
                Logged:
                Time Spent - Not Specified
                Not Specified