C++ Standard Library
  1. C++ Standard Library
  2. STDCXX-21

[Cygwin] wcodecvt.cpp:840: warning: comparison is always true due to limited range of data type

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 4.1.2
    • Fix Version/s: 4.1.3
    • Component/s: 22. Localization
    • Labels:
      None
    • Environment:

      Cygwin

      Description

      From http://mail-archives.apache.org/mod_mbox/incubator-stdcxx-dev/200509.mbox/%3c200509111213.j8BCDGMG006690@ms-smtp-03.rdc-nyc.rr.com%3e:

      -------- Original Message --------
      Subject: Cygwin build
      Date: Sun, 11 Sep 2005 08:13:38 -0400
      From: Lance Diduck <lancediduck@nyc.rr.com>
      Reply-To: stdcxx-dev@incubator.apache.org
      To: <stdcxx-dev@incubator.apache.org>

      Notes on Cygwin build _CYGWIN_ using gcc 3.4.4 BUILDTYPE=11s default
      modes
      [...]
      /cygdrive/c/stdcxx7/stdcxx-2005-07-19/src/wcodecvt.cpp: In function
      `std::codecvt_base::result _rw::_rw_libstd_do_out(const wchar_t*,
      const wchar_t*, const wchar_t*&, char*, char*, char*&, int, const
      _rw::_rw_codecvt_t*)':

      /cygdrive/c/stdcxx7/stdcxx-2005-07-19/src/wcodecvt.cpp:840: warning:
      comparison is always true due to limited range of data type

        Activity

        Martin Sebor created issue -
        Martin Sebor made changes -
        Field Original Value New Value
        Summary [Cygwin] wcodecvt.cpp:840: warning:
        [Cygwin] wcodecvt.cpp:840: comparison is always true due to limited range of data type
        [Cygwin] wcodecvt.cpp:840: warning: comparison is always true due to limited range of data type
        Martin Sebor made changes -
        Assignee Martin Sebor [ sebor ]
        Martin Sebor made changes -
        Status Open [ 1 ] In Progress [ 3 ]
        Martin Sebor added a comment -

        Compiles cleanly.

        Martin Sebor made changes -
        Resolution Fixed [ 1 ]
        Status In Progress [ 3 ] Resolved [ 5 ]
        Martin Sebor added a comment -

        Fix confirmed.

        Martin Sebor made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open In Progress In Progress
        3d 22h 4m 1 Martin Sebor 16/Sep/05 08:24
        In Progress In Progress Resolved Resolved
        55m 24s 1 Martin Sebor 16/Sep/05 09:20
        Resolved Resolved Closed Closed
        83d 22h 4m 1 Martin Sebor 09/Dec/05 06:24

          People

          • Assignee:
            Martin Sebor
            Reporter:
            Martin Sebor
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development