Uploaded image for project: 'Stanbol'
  1. Stanbol
  2. STANBOL-1432

ManagedSite returns 404 status on DELETE requests

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.12.0
    • Fix Version/s: 1.0.0, 0.12.1
    • Component/s: Entityhub
    • Labels:
      None

      Description

      As reported by Adrian Dinu in [1] the ManagedSite returns 404 on a DELETE request for an existing Entity.

      A first investigation showed that the Entity is in fact deleted, but a 404 status is returned anyway.

      As a workaround users can check for a 404 response the content of the response.

      • If the content is empty the entity was deleted
      • If the content contains a message starting with No Entity with the parsed Id no entity with the requests ID was found.

      The fix will ensure that successful delete requests will return a 200 response code. In addition in case a single entity is deleted the response will return the data of the deleted entity.

      [1] http://markmail.org/message/f6vgxx44iukngizk

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                rwesten Rupert Westenthaler
                Reporter:
                rwesten Rupert Westenthaler
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: