Sqoop
  1. Sqoop
  2. SQOOP-973

Sqoop2: Merge host, port and app to single server URL in Sqoop shell

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.99.2
    • Fix Version/s: 1.99.3
    • Component/s: None
    • Labels:
      None

      Description

      Currently user have to enter separately host, port and resource where the Sqoop2 server is running in our shell application. This seems to be inconsistent with other similar applications where user is supplying entire URL at once. I would therefore propose to change this. Proposed change would alter only shell behavior, server would remain untouched.

      1. SQOOP-973.2.patch
        8 kB
        Mengwei Ding
      2. SQOOP-973.1.patch
        7 kB
        Mengwei Ding

        Issue Links

          Activity

          Mengwei Ding added a comment -

          Setting status to "Patch available" to show this ticket in our review queue.

          ASF subversion and git services added a comment -

          Commit 20082c57d2533951c6f315c608c7b3df8616150b in branch refs/heads/sqoop2 from Jarek Jarcec Cecho
          [ https://git-wip-us.apache.org/repos/asf?p=sqoop.git;h=20082c5 ]

          SQOOP-973: Sqoop2: Merge host, port and app to single server URL in Sqoop shell

          (Mengwei Ding via Jarek Jarcec Cecho)

          Jarek Jarcec Cecho added a comment -

          Thank you Mengwei for your contribution!

          Hudson added a comment -

          Integrated in Sqoop2-hadoop100 #295 (See https://builds.apache.org/job/Sqoop2-hadoop100/295/)
          SQOOP-973: Sqoop2: Merge host, port and app to single server URL in Sqoop shell (Revision 20082c57d2533951c6f315c608c7b3df8616150b)

          Result = FAILURE
          jarcec : https://git-wip-us.apache.org/repos/asf?p=sqoop.git&a=commit&h=20082c57d2533951c6f315c608c7b3df8616150b
          Files :

          • client/src/main/java/org/apache/sqoop/client/shell/ShellEnvironment.java
          • client/src/main/java/org/apache/sqoop/client/shell/SetServerFunction.java
          • client/src/main/resources/client-resource.properties
          • docs/src/site/sphinx/CommandLineClient.rst
          • client/src/main/java/org/apache/sqoop/client/core/Constants.java
          Hudson added a comment -

          Integrated in Sqoop2-hadoop200 #300 (See https://builds.apache.org/job/Sqoop2-hadoop200/300/)
          SQOOP-973: Sqoop2: Merge host, port and app to single server URL in Sqoop shell (Revision 20082c57d2533951c6f315c608c7b3df8616150b)

          Result = SUCCESS
          jarcec : https://git-wip-us.apache.org/repos/asf?p=sqoop.git&a=commit&h=20082c57d2533951c6f315c608c7b3df8616150b
          Files :

          • client/src/main/java/org/apache/sqoop/client/shell/SetServerFunction.java
          • docs/src/site/sphinx/CommandLineClient.rst
          • client/src/main/resources/client-resource.properties
          • client/src/main/java/org/apache/sqoop/client/shell/ShellEnvironment.java
          • client/src/main/java/org/apache/sqoop/client/core/Constants.java
          Jarek Jarcec Cecho added a comment -

          The failure is caused by Jenkins memory issues.


            People

            • Assignee:
              Mengwei Ding
              Reporter:
              Jarek Jarcec Cecho
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development