Sqoop
  1. Sqoop
  2. SQOOP-958

Sqoop2: fix version tests in Mac OS X

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.0
    • Fix Version/s: 1.99.3
    • Component/s: test
    • Labels:
      None

      Description

      Version tests fail when executing them in Mac OS X.

      1. SQOOP-958.patch
        1 kB
        Abraham Elmahrek

        Activity

        Jarek Jarcec Cecho made changes -
        Fix Version/s 1.99.3 [ 12324298 ]
        Fix Version/s 2.0.0 [ 12319272 ]
        Hudson added a comment -

        Integrated in Sqoop2-hadoop200 #236 (See https://builds.apache.org/job/Sqoop2-hadoop200/236/)
        SQOOP-958: Fix white space handling when generating version info (Revision b94c22919e04f88bf916dff857a74b86e8048865)

        Result = SUCCESS
        kathleen : https://git-wip-us.apache.org/repos/asf?p=sqoop.git&a=commit&h=b94c22919e04f88bf916dff857a74b86e8048865
        Files :

        • common/src/saveVersion.sh
        • common/pom.xml
        Hudson added a comment -

        Integrated in Sqoop2-hadoop100 #236 (See https://builds.apache.org/job/Sqoop2-hadoop100/236/)
        SQOOP-958: Fix white space handling when generating version info (Revision b94c22919e04f88bf916dff857a74b86e8048865)

        Result = SUCCESS
        kathleen : https://git-wip-us.apache.org/repos/asf?p=sqoop.git&a=commit&h=b94c22919e04f88bf916dff857a74b86e8048865
        Files :

        • common/src/saveVersion.sh
        • common/pom.xml
        Kathleen Ting made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Fix Version/s 2.0.0 [ 12319272 ]
        Resolution Fixed [ 1 ]
        Kathleen Ting added a comment -
        Abraham Elmahrek made changes -
        Field Original Value New Value
        Attachment SQOOP-958.patch [ 12574599 ]
        Abraham Elmahrek added a comment -

        Patch attached.

        Abraham Elmahrek added a comment -

        The problem is not with Mac OS X, but with how version info is generated. The executable "saveVersion.sh" should consider whitespace.

        Abraham Elmahrek created issue -

          People

          • Assignee:
            Abraham Elmahrek
            Reporter:
            Abraham Elmahrek
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development