Sqoop
  1. Sqoop
  2. SQOOP-879

Sqoop2: NPE when deleting job object that do not have associated any submissions

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.99.1
    • Fix Version/s: 1.99.2
    • Component/s: None
    • Labels:
      None

      Description

      Removing job that do not have associated any submission will result in NullPointerException:

      sqoop:000> delete job --jid 3                    
      Exception has occurred during processing command 
      Server has returned exception: Exception: java.lang.Throwable Message: JDBCREPO_0012:Failure in metadata repository operation.
      Stack trace:
               at  org.apache.sqoop.repository.JdbcRepository (JdbcRepository.java:92)  
               at  org.apache.sqoop.repository.JdbcRepository (JdbcRepository.java:294)  
               at  org.apache.sqoop.handler.JobRequestHandler (JobRequestHandler.java:102)  
               at  org.apache.sqoop.handler.JobRequestHandler (JobRequestHandler.java:85)  
               at  org.apache.sqoop.server.v1.JobServlet (JobServlet.java:54)  
               at  org.apache.sqoop.server.SqoopProtocolServlet (SqoopProtocolServlet.java:95)  
               at  javax.servlet.http.HttpServlet (HttpServlet.java:643)  
               at  javax.servlet.http.HttpServlet (HttpServlet.java:717)  
               at  org.apache.catalina.core.ApplicationFilterChain (ApplicationFilterChain.java:290)  
               at  org.apache.catalina.core.ApplicationFilterChain (ApplicationFilterChain.java:206)  
               at  org.apache.catalina.core.StandardWrapperValve (StandardWrapperValve.java:233)  
               at  org.apache.catalina.core.StandardContextValve (StandardContextValve.java:191)  
               at  org.apache.catalina.core.StandardHostValve (StandardHostValve.java:127)  
               at  org.apache.catalina.valves.ErrorReportValve (ErrorReportValve.java:102)  
               at  org.apache.catalina.core.StandardEngineValve (StandardEngineValve.java:109)  
               at  org.apache.catalina.connector.CoyoteAdapter (CoyoteAdapter.java:293)  
               at  org.apache.coyote.http11.Http11Processor (Http11Processor.java:859)  
               at  org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler (Http11Protocol.java:602)  
               at  org.apache.tomcat.util.net.JIoEndpoint$Worker (JIoEndpoint.java:489)  
               at  java.lang.Thread (Thread.java:662)  
      Caused by: Exception: java.lang.NullPointerException Message: 
      Stack trace:
               at  org.apache.sqoop.repository.derby.DerbyRepositoryHandler (DerbyRepositoryHandler.java:731)  
               at  org.apache.sqoop.repository.JdbcRepository$10 (JdbcRepository.java:301)  
               at  org.apache.sqoop.repository.JdbcRepository (JdbcRepository.java:78)  
               at  org.apache.sqoop.repository.JdbcRepository (JdbcRepository.java:294)  
               at  org.apache.sqoop.handler.JobRequestHandler (JobRequestHandler.java:102)  
               at  org.apache.sqoop.handler.JobRequestHandler (JobRequestHandler.java:85)  
               at  org.apache.sqoop.server.v1.JobServlet (JobServlet.java:54)  
               at  org.apache.sqoop.server.SqoopProtocolServlet (SqoopProtocolServlet.java:95)  
               at  javax.servlet.http.HttpServlet (HttpServlet.java:643)  
               at  javax.servlet.http.HttpServlet (HttpServlet.java:717)  
               at  org.apache.catalina.core.ApplicationFilterChain (ApplicationFilterChain.java:290)  
               at  org.apache.catalina.core.ApplicationFilterChain (ApplicationFilterChain.java:206)  
               at  org.apache.catalina.core.StandardWrapperValve (StandardWrapperValve.java:233)  
               at  org.apache.catalina.core.StandardContextValve (StandardContextValve.java:191)  
               at  org.apache.catalina.core.StandardHostValve (StandardHostValve.java:127)  
               at  org.apache.catalina.valves.ErrorReportValve (ErrorReportValve.java:102)  
               at  org.apache.catalina.core.StandardEngineValve (StandardEngineValve.java:109)  
               at  org.apache.catalina.connector.CoyoteAdapter (CoyoteAdapter.java:293)  
               at  org.apache.coyote.http11.Http11Processor (Http11Processor.java:859)  
               at  org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler (Http11Protocol.java:602)  
               at  org.apache.tomcat.util.net.JIoEndpoint$Worker (JIoEndpoint.java:489)  
               at  java.lang.Thread (Thread.java:662) 
      
      1. bugSQOOP-879.patch
        0.9 kB
        Jarek Jarcec Cecho

        Issue Links

          Activity

          Hudson added a comment -

          Integrated in Sqoop2-hadoop200 #187 (See https://builds.apache.org/job/Sqoop2-hadoop200/187/)
          SQOOP-879: NPE when deleting job object that do not have associated any submissions (Revision b80b2d8e63043cea338ce34ea36e75ffac7aef06)

          Result = SUCCESS
          cheolsoo : https://git-wip-us.apache.org/repos/asf?p=sqoop.git&a=commit&h=b80b2d8e63043cea338ce34ea36e75ffac7aef06
          Files :

          • repository/repository-derby/src/main/java/org/apache/sqoop/repository/derby/DerbyRepositoryHandler.java
          Hudson added a comment -

          Integrated in Sqoop2-hadoop100 #174 (See https://builds.apache.org/job/Sqoop2-hadoop100/174/)
          SQOOP-879: NPE when deleting job object that do not have associated any submissions (Revision b80b2d8e63043cea338ce34ea36e75ffac7aef06)

          Result = SUCCESS
          cheolsoo : https://git-wip-us.apache.org/repos/asf?p=sqoop.git&a=commit&h=b80b2d8e63043cea338ce34ea36e75ffac7aef06
          Files :

          • repository/repository-derby/src/main/java/org/apache/sqoop/repository/derby/DerbyRepositoryHandler.java
          Cheolsoo Park added a comment -

          +1. Committed to sqoop2.


            People

            • Assignee:
              Jarek Jarcec Cecho
              Reporter:
              Jarek Jarcec Cecho
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development