Sqoop
  1. Sqoop
  2. SQOOP-871

Connector-level job-specific prop gives wrong help msg

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.99.1
    • Fix Version/s: 1.99.2
    • Component/s: sqoop2-client
    • Labels:
      None

      Description

      In the sqoop2 client I do "show connector --cid=1", and I see 3 forms that all seem to be specific to a particular connector (connector with cid=1 in this case). The forms are:

      1) Connection form (these are apparently the connection-specific props that will be prompted to the user when creating a connection on top of connector cid=1.

      2) Job form (these are apparently job-specific props that will be prompted to the user when creating a job on top of some connection that was in turn created on top of the connector with cid=1)

      The help for the job-specific props shows:
      Help: You must supply the information requested in order to create a connection object.
      ...but should say "job object" instead of "connection object".

      1. SQOOP-871.patch
        0.9 kB
        Will McQueen

        Activity

        No work has yet been logged on this issue.

          People

          • Assignee:
            Will McQueen
            Reporter:
            Will McQueen
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development