I'm excited to hear that you're interested in solving this issue. I would like to have unified usage of logger in entire Sqoop 2 code base. At the top of my head:
- Have unified name for logger object across entire code base. I believe that we already have this in place where all logger objects are called "LOG", but it do not hurts to verify that.
- Use the same logging packages and libraries. We're missing this one as for example:
private static final Logger LOG = Logger.getLogger(FrameworkManager.class);
public static final Log LOG =
Both files are using different packages and different idioms to get the logger object. I would prefer to have that unified.