Sqoop
  1. Sqoop
  2. SQOOP-629

Provide better exception handling during server-client communication

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.0
    • Fix Version/s: 1.99.1
    • Component/s: None
    • Labels:
      None

      Description

      Currently in case of an exception on the server side we're transferring exception's message, error code and printed stack trace (that is not displayed on the client at all). Would be great if this logic would be improved to transfer entire exception including all "caused by" exceptions. Also appropriate error printing on client side would be great.

      1. bugSQOOP-629.patch
        21 kB
        Jarek Jarcec Cecho
      2. bugSQOOP-629.patch
        20 kB
        Jarek Jarcec Cecho

        Issue Links

          Activity

          Bilung Lee added a comment -

          Thanks for contribution. Patch is committed.


            People

            • Assignee:
              Jarek Jarcec Cecho
              Reporter:
              Jarek Jarcec Cecho
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development