Uploaded image for project: 'Sqoop'
  1. Sqoop
  2. SQOOP-607

In-process Hive CLI driver does not work

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.4.3
    • Component/s: hive-integration
    • Labels:
      None

      Description

      Since the namespace migration, this does not work as org.apache.sqoop.util.ExitSecurityException is thrown, but then com.cloudera.sqoop.util.ExitSecurityException is checked.
      HiveImport should be updated to check for the new namespace - and possibly for backward compatibility the old namespace should be thrown.

        Attachments

        1. SQOOP-607.patch
          0.6 kB
          David Robson
        2. SQOOP-607.patch
          1 kB
          David Robson

          Issue Links

            Activity

              People

              • Assignee:
                david.robson David Robson
                Reporter:
                david.robson David Robson
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - 1h
                  1h
                  Remaining:
                  Remaining Estimate - 1h
                  1h
                  Logged:
                  Time Spent - Not Specified
                  Not Specified