Details

    • Type: Test
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.4.2
    • Fix Version/s: 1.4.3
    • Component/s: None
    • Labels:
      None

      Description

      Some unit test such as TestHBaseImport and TestHBaseQueryImport fail with timeout oftentimes. To prevent unexpected build failures, we should increase timeout.

      1. SQOOP-606.patch
        0.4 kB
        Cheolsoo Park

        Activity

        cheolsoo Cheolsoo Park added a comment -

        Doubling timeout limit. Skipping the review board as it is a trivial change.

        Thanks!

        jarcec Jarek Jarcec Cecho added a comment -

        I'm bypassing review board and giving my +1 here.

        jarcec Jarek Jarcec Cecho added a comment -

        Committed.

        Thank you for your contribution Cheolsoo!

        Jarcec

        hudson Hudson added a comment -

        Integrated in Sqoop-ant-jdk-1.6-hadoop20 #58 (See https://builds.apache.org/job/Sqoop-ant-jdk-1.6-hadoop20/58/)
        SQOOP-606: Increase unit test timeout. (Revision 9506b34ddf3cdd735619a7765e7fd97b3a509f4f)

        Result = SUCCESS
        jarcec : https://git-wip-us.apache.org/repos/asf?p=sqoop.git&a=commit&h=9506b34ddf3cdd735619a7765e7fd97b3a509f4f
        Files :

        • build.xml
        hudson Hudson added a comment -

        Integrated in Sqoop-ant-jdk-1.6-hadoop100 #63 (See https://builds.apache.org/job/Sqoop-ant-jdk-1.6-hadoop100/63/)
        SQOOP-606: Increase unit test timeout. (Revision 9506b34ddf3cdd735619a7765e7fd97b3a509f4f)

        Result = FAILURE
        jarcec : https://git-wip-us.apache.org/repos/asf?p=sqoop.git&a=commit&h=9506b34ddf3cdd735619a7765e7fd97b3a509f4f
        Files :

        • build.xml
        hudson Hudson added a comment -

        Integrated in Sqoop-ant-jdk-1.6-hadoop23 #192 (See https://builds.apache.org/job/Sqoop-ant-jdk-1.6-hadoop23/192/)
        SQOOP-606: Increase unit test timeout. (Revision 9506b34ddf3cdd735619a7765e7fd97b3a509f4f)

        Result = FAILURE
        jarcec : https://git-wip-us.apache.org/repos/asf?p=sqoop.git&a=commit&h=9506b34ddf3cdd735619a7765e7fd97b3a509f4f
        Files :

        • build.xml
        hudson Hudson added a comment -

        Integrated in Sqoop-ant-jdk-1.6-hadoop200 #43 (See https://builds.apache.org/job/Sqoop-ant-jdk-1.6-hadoop200/43/)
        SQOOP-606: Increase unit test timeout. (Revision 9506b34ddf3cdd735619a7765e7fd97b3a509f4f)

        Result = SUCCESS
        jarcec : https://git-wip-us.apache.org/repos/asf?p=sqoop.git&a=commit&h=9506b34ddf3cdd735619a7765e7fd97b3a509f4f
        Files :

        • build.xml
        jarcec Jarek Jarcec Cecho added a comment -

        Those failures are caused by some environmental issue on slave Ubuntu4. I'll file a infra ticket to get it resolved.

        Jarcec


          People

          • Assignee:
            cheolsoo Cheolsoo Park
            Reporter:
            cheolsoo Cheolsoo Park
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development