Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.4.2
    • Component/s: None
    • Labels:
      None

      Description

      This is due to recent update of hsqldb jar version. Updating the jar does not break the build but it breaks the execution of every SQOOP job, as Hadoop's classpath is prepended to Sqoop's classpath and hadoop contains previous version of hsqldb JAR.
      This is a class loading issue. hsqldb-1.8.0.10.jar from hadoop is loaded first and we have hsqldb-2.2.8.jar specific code in sqoop.

      Steps to reproduce:
      1. Checkout latest revision from SVN/GIT
      2. Build - "ant -Dhadoopversion <as_per_hadoop_version_you_have>"
      3. Try to run sqoop with any DBMS. You get -

      Exception in thread "main" java.lang.NoSuchMethodError: org.hsqldb.DatabaseURL.parseURL(Ljava/lang/String;ZZ)Lorg/hsqldb/persist/HsqlProperties;
      at org.hsqldb.jdbc.JDBCDriver.getConnection(Unknown Source)
      at org.hsqldb.jdbc.JDBCDriver.connect(Unknown Source)
      at java.sql.DriverManager.getConnection(DriverManager.java:582)
      at java.sql.DriverManager.getConnection(DriverManager.java:185)
      at org.apache.sqoop.manager.SqlManager.makeConnection(SqlManager.java:665)
      at org.apache.sqoop.manager.GenericJdbcManager.getConnection(GenericJdbcManager.java:52)
      at org.apache.sqoop.manager.SqlManager.execute(SqlManager.java:525)
      at org.apache.sqoop.manager.SqlManager.execute(SqlManager.java:548)
      at org.apache.sqoop.manager.SqlManager.getColumnTypesForRawQuery(SqlManager.java:191)
      at org.apache.sqoop.manager.SqlManager.getColumnTypes(SqlManager.java:175)
      at org.apache.sqoop.manager.ConnManager.getColumnTypes(ConnManager.java:262)
      at org.apache.sqoop.orm.ClassWriter.getColumnTypes(ClassWriter.java:1235)
      at org.apache.sqoop.orm.ClassWriter.generate(ClassWriter.java:1060)
      at org.apache.sqoop.tool.CodeGenTool.generateORM(CodeGenTool.java:82)
      at org.apache.sqoop.tool.ImportTool.importTable(ImportTool.java:390)
      at org.apache.sqoop.tool.ImportTool.run(ImportTool.java:476)
      at org.apache.sqoop.Sqoop.run(Sqoop.java:145)
      at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:65)
      at org.apache.sqoop.Sqoop.runSqoop(Sqoop.java:181)
      at org.apache.sqoop.Sqoop.runTool(Sqoop.java:220)
      at org.apache.sqoop.Sqoop.runTool(Sqoop.java:229)
      at org.apache.sqoop.Sqoop.main(Sqoop.java:238)
      at com.cloudera.sqoop.Sqoop.main(Sqoop.java:57)

      Unless, you set this on command-line:
      export HADOOP_USER_CLASSPATH_FIRST=true

      Haven't tried ahead but it should also fail when Sqoop internally triggers a Hadoop JOB. This is just a speculation, will confirm this.

      1. SQOOP-524.patch
        0.5 kB
        Abhijeet Gaikwad
      2. SQOOP-524 -1.patch
        1 kB
        Abhijeet Gaikwad
      3. SQOOP-524-2.patch
        2 kB
        Abhijeet Gaikwad

        Issue Links

          Activity

          cheolsoo Cheolsoo Park added a comment -

          Hi Abhijeet, thanks for reporting this problem. In fact, this is the same issue that I had with hadoop YARN where hdsqldb-2.0.0.jar from hadoop YARN is loaded before hsqldb-1.8.0.jar.

          Unfortunately, I think that we should build two versions of Sqoop for MR1 and MR2? If this is just a build issue, it is not too hard to solve; however, code change is required to get unit test passing with each version of hsqldb.

          Thoughts?

          jarcec Jarek Jarcec Cecho added a comment -

          Tests for CDH3 and hadoop 1.0.0 are passing correctly, so I'm wondering - could changing order of loading jars would be sufficient? Load Sqoop lib jars before hadoop I mean.

          Jarcec

          cheolsoo Cheolsoo Park added a comment - - edited

          Hi Jarcec, I haven't confirmed this myself, so I might be wrong here.

          According to Abhijeet, setting HADOOP_USER_CLASSPATH_FIRST will make the problem go away. Then can we do the followings?
          1) set HADOOP_USER_CLASSPATH_FIRST in sqoop-configure.sh or somewhere
          2) put SQOOP_CLASSPATH before HADOOP_CLASSPATH

          so the hsqldb jar from Sqoop is always used?

          abhijeet_gaikwad Abhijeet Gaikwad added a comment - - edited

          Just setting HADOOP_USER_CLASSPATH_FIRST=true did the magic for me. Approach sounds good, but would that create any instabilities in hadoop?

          abhijeet_gaikwad Abhijeet Gaikwad added a comment -

          All tests pass - "ant test -Dhadoopversion=100"

          As this is a small change, am skipping review board formality. Let me know your suggestions here as comments.

          abhijeet_gaikwad Abhijeet Gaikwad added a comment -

          While testing my patch locally, found that with hadoopversion=100, two hsqldb JARs of different versions are getting copied in SQOOP_CLASSPATH. Found two jars at these locations after build:
          1. $SQOOP_HOOME/build/ivy/lib/sqoop/hadoop100test/hsqldb-1.8.0.10.jar
          2. $SQOOP_HOOME/build/ivy/lib/sqoop/hadoop100test/hsqldb-2.2.8.jar

          Just wanted a quick confirmation, is this some issue with my local setup - I checked these after clearing my ivy cache, result was same?

          Let me know your suggestions, will upload a new patch if any changes required.

          cheolsoo Cheolsoo Park added a comment - - edited

          Hi Abhijeet, thanks for your patch!

          two hsqldb JARs of different versions are getting copied in SQOOP_CLASSPATH

          To answer your question, it is a bug too. hsqldb-1.8.0.10.jar is being pulled by some dependency library, so we must exclude it in ivy.xml. In fact, I excluded it when hadoopversion=23, but it should be excluded globally regardless of the hadoopversion. The good thing is that hqsldb-2.2.x has a different org attribute from hsqldb-1.8.x, so excluding hsqldb-1.8.x does not prevent us from downloading hsqldb-2.2.x.

          Can you please add the following change to your patch? This fixes the problem.

          --- ivy.xml	(revision 1366535)
          +++ ivy.xml	(working copy)
          @@ -74,7 +74,6 @@
                 rev="${hadoop.version}" conf="hadoop23->default">
                 <artifact name="hadoop-common" type="jar" />
                 <artifact name="hadoop-common" type="jar" m:classifier="tests"/>
          -      <exclude org="hsqldb" module="hsqldb"/>
               </dependency>
               <dependency org="org.apache.hadoop" name="hadoop-hdfs"
                 rev="${hadoop.version}" conf="hadoop23->default">
          @@ -150,6 +149,7 @@
                 <exclude org="com.cloudera.cdh" module="zookeeper-ant" />
               </dependency>
           
          +    <exclude org="hsqldb" module="hsqldb"/>
               <exclude org="org.apache.hadoop" module="avro"/>
               <exclude org="commons-daemon" module="commons-daemon" />
          
          abhijeet_gaikwad Abhijeet Gaikwad added a comment -

          ant test -Dhadoopversion=100 [success]

          With this fix, I don't see previous version hsqldb JAR in classspath. Thanks cheolsoo for your suggestions.

          abhijeet_gaikwad Abhijeet Gaikwad added a comment -

          Cannot go ahead with the release without this fix.

          jarcec Jarek Jarcec Cecho added a comment -

          Overall changes seems fine to me, just can we put more descriptive comment to the bin/configure-sqoop script instead of "helps pick up 2.2.0 version of hsqldb jar"? Some small introduction to this issue and maybe explicitly state that this was done to resolve SQOOP-524?

          My concern here is that we will not remember why we've done that after a year, so I would like to make sure that we will have enough information to remember.

          Jarcec

          abhijeet_gaikwad Abhijeet Gaikwad added a comment -

          As suggested by Jarcec, added a more descriptive comment.
          Thanks Jarcec.

          jarcec Jarek Jarcec Cecho added a comment -

          Thank you Abhijeet for your change - I like that comment It's very, very descriptive.

          Since it's very simple patch, I'm bypassing review board and giving +1 here.

          jarcec Jarek Jarcec Cecho added a comment -

          Committed revision 1367608.

          Thanks for your contribution Abhijeet!

          Jarcec

          hudson Hudson added a comment -

          Integrated in Sqoop-ant-jdk-1.6 #129 (See https://builds.apache.org/job/Sqoop-ant-jdk-1.6/129/)
          SQOOP-524. hsqldb jar update regression.

          (Abhijeet Gaikwad via Jarek Jarcec Cecho) (Revision 1367608)

          Result = SUCCESS
          jarcec :
          Files :

          • /sqoop/trunk/bin/configure-sqoop
          • /sqoop/trunk/ivy.xml
          hudson Hudson added a comment -

          Integrated in Sqoop-ant-jdk-1.6-hadoop20 #10 (See https://builds.apache.org/job/Sqoop-ant-jdk-1.6-hadoop20/10/)
          Changelog update for 1.4.2

          Add:

          (Cheolsoo Park via Jarek Jarcec Cecho) (Revision 1372828)

          Result = SUCCESS
          jarcec :
          Files :

          • /sqoop/trunk/CHANGELOG.txt

          jarcec :
          Files :

          • /sqoop/trunk/bin/configure-sqoop
          • /sqoop/trunk/ivy.xml
          • /sqoop/trunk/ivy/libraries.properties
          • /sqoop/trunk/ivy/sqoop-test.xml
          • /sqoop/trunk/ivy/sqoop.xml
          • /sqoop/trunk/src/java/org/apache/sqoop/metastore/hsqldb/HsqldbJobStorage.java
          • /sqoop/trunk/src/java/org/apache/sqoop/metastore/hsqldb/HsqldbMetaStore.java
          • /sqoop/trunk/src/test/com/cloudera/sqoop/TestAvroExport.java
          • /sqoop/trunk/src/test/com/cloudera/sqoop/TestAvroImport.java
          • /sqoop/trunk/src/test/com/cloudera/sqoop/TestExport.java
          • /sqoop/trunk/src/test/com/cloudera/sqoop/TestMultiCols.java
          • /sqoop/trunk/src/test/com/cloudera/sqoop/hive/TestHiveImport.java
          • /sqoop/trunk/src/test/com/cloudera/sqoop/manager/DirectMySQLExportTest.java
          • /sqoop/trunk/src/test/com/cloudera/sqoop/manager/JdbcMySQLExportTest.java
          • /sqoop/trunk/src/test/com/cloudera/sqoop/manager/MySQLCompatTest.java
          • /sqoop/trunk/src/test/com/cloudera/sqoop/manager/OracleCompatTest.java
          • /sqoop/trunk/src/test/com/cloudera/sqoop/manager/OracleExportTest.java
          • /sqoop/trunk/src/test/com/cloudera/sqoop/mapreduce/db/TestDataDrivenDBInputFormat.java
          • /sqoop/trunk/src/test/com/cloudera/sqoop/testutil/ManagerCompatTestCase.java
          hudson Hudson added a comment -

          Integrated in Sqoop-ant-jdk-1.6-hadoop23 #140 (See https://builds.apache.org/job/Sqoop-ant-jdk-1.6-hadoop23/140/)
          Changelog update for 1.4.2

          Add:

          (Cheolsoo Park via Jarek Jarcec Cecho) (Revision 1372828)

          Result = SUCCESS
          jarcec :
          Files :

          • /sqoop/trunk/CHANGELOG.txt

          jarcec :
          Files :

          • /sqoop/trunk/bin/configure-sqoop
          • /sqoop/trunk/ivy.xml
          • /sqoop/trunk/ivy/libraries.properties
          • /sqoop/trunk/ivy/sqoop-test.xml
          • /sqoop/trunk/ivy/sqoop.xml
          • /sqoop/trunk/src/java/org/apache/sqoop/metastore/hsqldb/HsqldbJobStorage.java
          • /sqoop/trunk/src/java/org/apache/sqoop/metastore/hsqldb/HsqldbMetaStore.java
          • /sqoop/trunk/src/test/com/cloudera/sqoop/TestAvroExport.java
          • /sqoop/trunk/src/test/com/cloudera/sqoop/TestAvroImport.java
          • /sqoop/trunk/src/test/com/cloudera/sqoop/TestExport.java
          • /sqoop/trunk/src/test/com/cloudera/sqoop/TestMultiCols.java
          • /sqoop/trunk/src/test/com/cloudera/sqoop/hive/TestHiveImport.java
          • /sqoop/trunk/src/test/com/cloudera/sqoop/manager/DirectMySQLExportTest.java
          • /sqoop/trunk/src/test/com/cloudera/sqoop/manager/JdbcMySQLExportTest.java
          • /sqoop/trunk/src/test/com/cloudera/sqoop/manager/MySQLCompatTest.java
          • /sqoop/trunk/src/test/com/cloudera/sqoop/manager/OracleCompatTest.java
          • /sqoop/trunk/src/test/com/cloudera/sqoop/manager/OracleExportTest.java
          • /sqoop/trunk/src/test/com/cloudera/sqoop/mapreduce/db/TestDataDrivenDBInputFormat.java
          • /sqoop/trunk/src/test/com/cloudera/sqoop/testutil/ManagerCompatTestCase.java
          hudson Hudson added a comment -

          Integrated in Sqoop-ant-jdk-1.6-hadoop100 #10 (See https://builds.apache.org/job/Sqoop-ant-jdk-1.6-hadoop100/10/)
          Changelog update for 1.4.2

          Add:

          (Cheolsoo Park via Jarek Jarcec Cecho) (Revision 1372828)

          Result = SUCCESS
          jarcec :
          Files :

          • /sqoop/trunk/CHANGELOG.txt

          jarcec :
          Files :

          • /sqoop/trunk/bin/configure-sqoop
          • /sqoop/trunk/ivy.xml
          • /sqoop/trunk/ivy/libraries.properties
          • /sqoop/trunk/ivy/sqoop-test.xml
          • /sqoop/trunk/ivy/sqoop.xml
          • /sqoop/trunk/src/java/org/apache/sqoop/metastore/hsqldb/HsqldbJobStorage.java
          • /sqoop/trunk/src/java/org/apache/sqoop/metastore/hsqldb/HsqldbMetaStore.java
          • /sqoop/trunk/src/test/com/cloudera/sqoop/TestAvroExport.java
          • /sqoop/trunk/src/test/com/cloudera/sqoop/TestAvroImport.java
          • /sqoop/trunk/src/test/com/cloudera/sqoop/TestExport.java
          • /sqoop/trunk/src/test/com/cloudera/sqoop/TestMultiCols.java
          • /sqoop/trunk/src/test/com/cloudera/sqoop/hive/TestHiveImport.java
          • /sqoop/trunk/src/test/com/cloudera/sqoop/manager/DirectMySQLExportTest.java
          • /sqoop/trunk/src/test/com/cloudera/sqoop/manager/JdbcMySQLExportTest.java
          • /sqoop/trunk/src/test/com/cloudera/sqoop/manager/MySQLCompatTest.java
          • /sqoop/trunk/src/test/com/cloudera/sqoop/manager/OracleCompatTest.java
          • /sqoop/trunk/src/test/com/cloudera/sqoop/manager/OracleExportTest.java
          • /sqoop/trunk/src/test/com/cloudera/sqoop/mapreduce/db/TestDataDrivenDBInputFormat.java
          • /sqoop/trunk/src/test/com/cloudera/sqoop/testutil/ManagerCompatTestCase.java

            People

            • Assignee:
              abhijeet_gaikwad Abhijeet Gaikwad
              Reporter:
              abhijeet_gaikwad Abhijeet Gaikwad
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development